No longer able to edit the zwo files for custom workouts directly

Since I have somewhat complex workouts, I’ve resorted to editing the .zwo files directly so I can easily create my workouts. I do this on Windows, so after creating the workout in the application I just edit the workout file within Documents folder to add the relevant repeats and steps in the file itself. After loading the workout again within the app, this would result in the correct workout appearing on Zwift.

It seems that with the last update, this no longer works. I now noticed a file within the directory, which I did not notice before, that contains the list of all workouts, where it includes a checksum field for each workout along with some other data.

My guess is that the Zwift app is now actively ignoring files that are edited, because they don’t match the checksum field within that file, that registers all the workouts.

Any chance we could get this behaviour of freely updating the zwo files back? Or, if my guess is correct, share the checksum function so I can at least edit the checksum value manually?

This is a big deal because it saves a lot of time for any tech-savvy user. Hopefully we can get this back working again instead of wasting considerable time dragging things in the interface.


Hi @Jose_Gomes welcome to Zwift forums.

Would you take a screenshot of what you’re seeing please? We’re not clear on what you’re seeing vs what you expect to see.

I have exactly the same problem as you. I have tried deleting the .zwo files manually from the Workouts folder, but every time I start Zwift the files are downloaded again and the workouts.files always include the 0 line for those particular edited workout files. I have also tried to delete the workouts.files file and my whole Workouts folder, but it does not work, everything downloads again once I start Zwift and the checksum field remains as “0”.

As you can see in the screenshot of my workouts.files, the workout New_workout.zwo is a workout created with Zwift and later on text edited. Now it has checksum = 0 and it does not work, I can not see in the workouts list inside Zwift. All the other files in the screenshot have not been edited since months, they have the right checksum value and they work properly.

I don’t know exactly what happened, but yesterday my macOS Zwift app updated to v1.52 and the problem is now solved. I can see in the workouts.files that the checksum field is not zero anymore for my edited .zwo files and I can see and select them in the app.