No heart rate tracking with garmin fenix 7 and zwift hub

When i pair elite novo trainer, i am able to track heart rate with garmin watch which then gives training effect etc.

Since upgrading to Zwift Hub, i can no longer track heart rate. When it pairs with Zwift Hub the heart rate on activites is blank. Anyone else faced this ?

Hey Peter! Welcome to the forums! Are you pairing the Fenix to the Zwift hub or to the game directly? I believe the Zwift hub can bridge ant + to Bluetooth so there could be some interference between the two.

Ive tried both. Connecting to the game gives a static incorrect heart rate number.
Connecting the watch to the Zwift Hub and starting the indoor bike activity on the watch produces a — heart rate. I then connected the watch back to the Elite Novo - starts working.

Where is the heart rate blank? On the Zwift game app, or on a Garmin app? Please clarify?

Is it possible that the watch’s HR signal is still bonded to the Elite trainer or to something else (another app)?

I experience exactly the same problem . My fennix 7 connects with my Tacx Fluid Smart and controls the trainer + displays HR data when in Indoor cycling mode . Once upgraded to Zwift hub I lost Heart rate data input when training Indoor Cycling . The HR data does not come up in training stats either . HR rate broadcast still possible though

I recommend to check how many connections your HR strap supports and then go from there.

I had similar issues and was able to resolve it as follows:

  • I have Wahoo Tickr which has 2xBT and Ant+ (unlimited). In the most frequent case I use 4 connections that consume HR - phone with TrainerRoad, tablet with Zwift, Fenix 7 watch, Wahoo Headwind

Here is how I solved my HR connectivity issues:

  • TrainerRoad on phone - must connect via BT (1st channel)
  • Zwift on tablet via BT (2nd channel)
  • Fenix 7 via Ant+ (!!!). It was sometimes connecting via BT which caused that HR was not available on TR or Zwift. There is an easy fix - under Settings/Sensors - turn the HR BT sensor as off and it will pickup the Ant+ channel
  • Wahoo Headwind is easy because it only goes via Ant+

I hope this may help.