No connection flux s and zwift on macbook pro

I’m having problems pairing Zwift on my macbook pro with my Tacx Flux S.
I can connect via my iPhone ( zwift app and companion app) so I know there’s an output from the Tacx, but using the iPhone is far too small for me when cycling. Also the bridgemethod with the companion app isn’t working verry well. The resistance goes all over the place when the gradient goes over 4%.

3 weeks ago, everything was working verry well. Please fix this!

Hi @Bart_Tourne
Welcome to Zwift forums!

I looked at your session logs on our server for January 5 and 6. I can see several login / logouts on both days from both the Macbook and the iPhone. Each of those “sessions” only lasted a few minutes, so I am sensing this is because of the connection failure, yes? That must have been frustrating.

However, there was one session today (Jan 6) that listed six minutes @ 12:00pm GMT, where the Macbook succesfully registered the Tacx as Bluetooth cadence, power and control trainer sources. Were you able to ride in-game for those 6 minutes, and if so, did you see the avatar move and register distance travelled?

Since you are a very experienced Zwifter, I trust that you know you can not have the iPhone and Macbook logged in at the same time. To define that further, you don’t want the game app running on a second device at the same time to avoid a conflict between two logged-in devices.

If you end the iPhone session, and force-close the game on the iPhone, will the Macbook then allow you to connect properly?

On jan 6 I rode 15 minutes using the bridgemethod with my iPhone. During that session the resistance fluctuated suddenly, so I stopped the session.
After this I rode for +1 hour using the zwift game app on my phone without any problems.
Force-closing the game I haven’t tried yet.

Hi there - seems like I have the same kind of problem, just finished a warmup and suddenly my little man stops dead.

I’m using a Tacx Flow with a Macbook Pro and Zwift companion on a spare mobile. Connected via Mac and Phone Bluetooth but Zwift started connecting and disconnecting like it was going out of fashion.

Eventually got a message saying ‘A Bluetooth Serial Failure has Occurred. Failed to open an RF Comm Serial Channel. Check if authentication needs to be enabled in your device’. This sounds very bad.

Turned everything off and on again. I’ve disconnected all my Bluetooth connections on the mac now but not tried it again since.

Will it always be like this or will all this tech start talking nicely one day? Shall I just get some winter gear and forget the whole thing?

Hi all,

I’m having a similar issue. The zwift app on my MacBook Air doesn’t recognise my tacx flux s, but my iPhone does.

I’ve tried deleting zwift on my iPhone, but the Mac still doesn’t pick it up. I’ve deleted/ restarted the zwift app on my Mac but still nothing.

Does anyone have l any other ideas? Or has this happened to anyone else and they’ve found out how to solve the problem?

Thanks!
Paul