New update today

I tried to install the latest update yesterday on my windows 10 PC. I keep getting the following message which prevents it installing.
The .NET framework 4.7.2 is not supported on this operating system.
Could anyone help please?

Win10 fully updated?

Is .NET 4.7.2 supported by Win10?

I tried doing any updates outstanding on Win 10 . Not too sure if .net 4.7.2 is supported actually

Hi, were you able to resolve this issue ?

Hi mate. Yes.
It was to do with windows 10. It hadn’t updated fully so was blocking the zwift update. All’s good now though