Issues with running app on laptop, error Net framework 3.5

Can’t open zwift on hp laptop running windows 10, fault for missing Net
framework 3.5,
Have tried a lot of cures all unsuccessful, Microsoft are not a huge help,
Has anyone successfully fixed this issue ?

Open Control Panel>Programs and Features
On the left-hand side click on Turn Windows features on or off
Make sure that .NET Framework 3.5 (includes .NET 2.0 and 3.0) is checked.

By default .NET 3.5 is not installed on Windows 10 computers.

Have tried the above, still won’t let me download 3.5 and then when go back into settings the box is unchecked again.

Are you an administrator of your computer?

Is this a work computer?

Yes I’m the admin, it’s a home laptop.

Is it fully up to date?

Yes, latest windows 10 updates downloaded .

What is the version/build of Windows 10?

Is it a 64 bit version of Windows 10?

Version 1903 64 bit

Try upgrading to Windows 10 1909 at least, 2004 is the most recent.

1 Like

Have tried to download all recent updates, maybe it’s an issue with windows not updating properly :thinking:

Had to manually download windows version 2004 as auto download was not completing the download to 100% was then able to download Net framework 3.5, thanks for your help :+1: