My Zwift Won't Launch

I tried everything I was advised to try then a new install after deleting the advised files.I get this message: Hmmm… can’t reach this page

It looks like the webpage at (won’t let me post links) might be having issues, or it may have moved permanently to a new web address.

My internet seems ok? 37down and 9up. Windows 10 plus all updates.Last used zwift on march 30th and all ok then.Latest launcher version.Won’t start from zwift in start button either.I shut off kaspersky firewall and still wouldn’t start.Cleaned windows edge history etc then clean install and still won’t work.

and 22ms ping

Hi @S_Shorland

Welcome back!

I’m sorry that you’re getting that error message when trying to get a new copy of Zwift. You should be able to download a new copy at: Download Zwift on iOS, MAC, PC, or Android Devices | Zwift

If you’re having issues reaching that link in one browser, try a different browser to see if that helps any.

Let us know how this goes.

1 Like

Try running it as administrator? Sounds funny, but sometimes it’ll work. Good troubleshooting step, JIC.

Hello and thanks for responding.I was busy but just tried to launch from the desktop icon and it asked me to login and it launched.(Billy told me he was sending my case to the fault team proper and maybe they did something? My error message was that the page was not responding or had moved or something similar.So I logged on with my password and it went through all the blue screen messages ‘rest days are important’ etc until ‘ride on’ and then it said oops wrong password.It asked me to login as soon as I pressed the launch icon which I did.Would it have run if I’d inputted the wrong info? And if it would have,how do I find my zwift password,please? (I’m pretty sure i entered the password correctly but we’re all human.

Spoke too soon.I restarted the computer and now we’re back to page unreachable again.