Minoura Kagura - spindown and resistance issues

Just bought a Minoura Kagura LST9200 and facing some very bothering issues even after two days of troubleshooting. While I understand Zwift requires some fine tuning it’s rather frustrating and I’m wondering if I have wasted my money buying a smart trainer. I am using Zwift on Windows and connected to trainer using Bluetooth through the Companion app.

Firstly I am unable to find the spindown wrench option in the Pair Device screen. I understand that Zwift had recently brought back this feature for many trainers including the Kagura but still not yet reflecting for me.

Second and most important issues with the resistance. Though I managed to get some resistance on my first test ride, I am not getting any resistance whatsoever ever since. Tried all sorts of methods mentioned by fellow zwifters in the forums such as unpairing the device from all other apps, re-pairing, etc… but no luck. Even installed Zwift on Android but not feeling any resistance in 6-8 degree climbs with trainer difficulty set to maximum.

Could this be a Bluetooth related limitation? Any suggestions to sort this out?

Calibration icon would probably show up if you were using ant+ or if you were using an iPad

I was going to say get your manufacture’s app and use that for calibration but upon reading/skimming this in depth review https://www.dcrainmaker.com/2018/09/minoura-kagura-trainer.html
I see that the app doesn’t provide that function! Which is very weird. Have a read of that if you haven’t, you might learn some things about your trainer.

As for resistance, make sure you are pairing your trainer as a controllable and not just as a power source.

Does you computer not have Bluetooth? Why are you connecting it through your phone? The more things in the chain the more variables there are to check and chances for things to go wrong.

Thanks Ben, may be i did clarify properly in my post - I am connected to computer via bluetooth and companion app but since both issues could not be sorted i tried using android app to troubleshoot and still facing the issue. So my primary mode of using Zwift is the computer.

I did read that spindown Bluetooth FTMS is enabled for Minoura Kagura - Game Update - March 27, 2020?
Apparently the app that is mentioned by DCrainmaker does not exist anymore in Play Store so that’s a dead end but as an alternative I can do the spindown using apps of other manufacturers such as Wahoo Fitness.

The trainer is connected both as power and controllable and there is no connection dropouts during the ride. Un-paired and re-paired but still no luck with the resistance.

Ok. If I were you I’d check if it works with another cycling app (they should all have free trials that don’t require credit card details). See if the resistance works on them. If it doesn’t then contact your manufacturer as the unit might be dodgy.

My first test ride did give me resistance on climbs so hard to digest it could be a faulty machine. I updated the trainer firmware once again and let me give a try with the other apps.

It’s a sigh of relief, the trainer provides resistance seamlessly on Kinomap so this definitely seems to be a Zwift issue

Ok. Good to know it’s not the trainer.

I’d suggest sending your zwift logs to zwift support and giving them a run down of what you have discovered.

Zwift support has been inundated though so it will take over a week to hear back from them so make sure you provide them with all the information at first. Every additional email to them will take more time.

Good luck.

Thanks Ben, I shall update this post once I hear back from Zwift support.

UPDATE: Zwift support hasnt got back to me yet (understandably due to influx of tickets they have been getting) but all of a sudden resistance got working on Android yesterday and is staying stable today too.

Since I’m not having the same luck with Windows I bought an ANT+ dongle/antenna; it is now in shipment and i should get it soon. I presume the spindown wrench may also show up when connecting via ANT+ FEC.

Meanwhile, I had also raised a concern with the manufacturer of the trainer Minoura sharing my frustrations about the inability to a spindown calibration since they do not have an app of their own. I received a response within 24 hours which is very good, from a person called Takashi Minoura (yes, the surname was surprising so I googled it and it appears could be the Vice President of the company!). He confirmed that they are making some changes to their latest firmware so the spindown calibration will work fine with Zwift.

Posting this update since i could not find much details about Minoura smart trainers in the Zwift forums and across the internet. It could be because the trainers are not very popular however from my experience so far i’m loving the machine for the Japanese build quality and design. Their 80+ years of experience in producing cycling products surely can be seen in their products. The specs (2000W & 20% gradient) are also much better than many others in the market. An area for improvement is to create brand awareness within the cycling community and social presence. A much modern technical manual and troubleshooting guide on their website plus an app of their own to update trainer firmware, ERG workouts, etc… will also help.


Hi Jose, it’s great to find another Minoura Kagura LST9200 user!!
I had same problems as you, but I also love the trainer. With ANT+ I could calibrate with Zwift.
I also asked Mr.Minoura about problems, and same answers as yours. I hope we’ll get a new firmware soon to update our trainers.

I read the review recomended They make the spindown with TrainerRoad app

I had the same issue but now it’s worse. I couldn’t zwift with my LSD9200 even though it shows connected