Milestone Pod Server Communication Error

I’ve been trying to login to the Milestone App for a few days now but keep getting a Server Communication Error. I don’t understand why I need to login to the app in the base case to get at my data as it should all be available on the phone, but since I can’t login I can’t get anything. Please fix!


I’ve been getting exactly the same error and Zwift are simply not interested in the Milestone app or the running metrics it provides. They need to remove the log on requirement so we can continue to access the Milestone App and the valuable data which should be ours but no longer accessible. Alternatively they could open source the App and code releasing it on something like Github so others could develop it. Doing nothing and ignoring us is simply unacceptable.

I’ve tried logging support cases, posted on the Zwift Run forum and no response from Zwift other than a statement to say they no longer support the app but you can use Zwift Run. I’ve tried to tell them I have no intentions of using Zwift run because that doesn’t help me get to my data. I run outside not on a tredmill and Zwift run only provides cadence and pace data from the pod.

1 Like