Man Will Not Move with WattBike


(Karl Bolland) #1

Hi,

I have connected my Wattbike (with Model B) on latest firmware and I have successfully connected the bike via a Garmin Ant+.

But when I launch the race I cannot get the cyclist to move at all. Has anybody managed to get their Wattbike to work with Zwift? If so can you let me know how you have set it up?

Any help would be greatly appreciated. 

Karl


(Eric Min) #2

Hi Karl,

There are many Wattbike users. I suspect you are not using a USB extension cable? The ANT+ dongle needs to sit directly under the Wattbike head unit. 

Eric


(Karl Bolland) #3

Thanks Eric,

The laptop/dongle is right next to the bike so within 40cm. So do I need to have the dongle physically underneath the head unit for it to work?

Karl 


(Eric Min) #4

That should be fine.

Basic question – did you actually pair your Wattbike in the Zwift pairing screen? 


(Karl Bolland) #5

I managed to get the bike to make the buttons on the config screen go colourful which I think means the bike and software have paired. 

Does that sound like I have done it correctly?

Karl


(Eric Min) #6

https://support.zwift.com/hc/en-us/articles/204587825-How-to-Start-Riding-in-Zwift

You’ll find the pairing screen on this page. Just want to confirm you’ve gone through this screen and paired your Wattbike as the power source. 


(Karl Bolland) #7

Hi Eric,

Yes I did that I got the icons to go blue. Can you confirm what trainer I should select for the Wattbike and also which option is best to select e.g. ‘Speed Sensor + Classic Trainer’?

Thanks for your help.  


(Eric Min) #8

Wattbike should come up as a listed power source. If Wattbike has a built in cadence sensor, you’ll see it also listed as a cadence sensor. No need to select “Speed sensor + Classic” since the Wattbike has real power. 


(Karl Bolland) #9

Thanks Eric,

I will have a look and see with all the above if I can sort it out.

I will let you know how I get on.


(Eric Min) #10

Excellent. 


(Karl Bolland) #11

Hi Eric,

Just to let you know I got it working. I firstly removed the Garmin program re installed Zwift. Then re installed Zwift. The second thing I did which I had not done before was launch a profile on the Wattbike itself. As soon as I did this it worked as expected.

Thanks for your help!

Karl 


(Eric Min) #12

Glad it worked out.