Magene S3+ does not got asleep - always connected

Hi there,

I’ve bought 2 units of Magene S3+ cad/spd sensors but they never go asleep!
They were supposed to enter “sleep mode” after 1min static in order to save battery, but they are showed as “connected” all the time at my Garmin Fenix 5x settings/sensors/ page.
I do haver several others sensors and they correctly apear as “searching” when not operating.
I’m using ANT+.
I’ve already entered Magene Utility app and paired both with BT (IOS) and there were no option for firmware upgrade so imagine they have the latest version…
I ask because I find hard to get 2 units with the exact same problem…
Other wise I’ll have to return them.

Thank you very much.