Lost Training Plan Progress [Nov 2022] [1.31]

Hi, marking the single activities in the plan (Android App) works, but this status is not visible in the compenion app! I think it also will not be counted for the plan completion batch!?

I was just under half way through the FTP development plan when the problem happened. I reported it to Zwift straight away and got a reply very quickly saying that they were working on a solution and not to re-enrol. I didn’t therefore re-enrol but I did tick the completion boxes on each of the missing workouts as there was no advice from Zwift to the contrary. When I next logged on no completed workouts showed but they are back now following the update; The problem I have that the workouts all now have the same date, which is the date I ticked the completion boxes. These dates are now different from the original correct ones in the Companion App and in Strava. I’ve raised the issue with Zwift and they keep referring me to this forum saying the answer is here, which it isn’t, unless I’ve missed a posting.

4 Likes

Hi, i’ve a problem with one of my Triathlon Academy rides, is this the same problem? If so, Patch 1.31.1 didn’t help. I’m already in contact with the support, but no results so far.

I rode the long ride #3 last week and it did’nt count yet. All the fit files are correct and also the exports to strava and trainingpeaks worked fine. It’s also shown correctly my zwift activity feed.

1 Like

I still have problem with FTP Builder Plan, they pass me from one to other losing lot of time, asked for mail to them .log and .fit files.
I have done all that has been requested and they are disappered!
I’m very disappointed for this unprofessional way to approach

4 Likes

Hello, the problem is still not solved, I enrolled again when you had your critical issue because I had to train, and now I totally lost my Build me up plan progress. Please fix this it’s not possible for a software like your to loose the data of the people. And don’t mark this thread as solved

Zwift, please, as others have also politely asked, don’t mark this thread as [SOLVED] when it clearly hasn’t been for many users. I asked a reasonable question that if the lost plan data and any new data after re-enrolling would be added together if and when the problem IS actually solved but that doesn’t appear to be the case as I still only have data from the last 2 rides of week three FTP builder. The rest of the plan I’d previously completed I just clicked on ‘did it’ hoping they would be repopulated with the “lost” data but have had no reply. Disappointed doesn’t cover it.

3 Likes

There are two different problems here. What this started as was the non-mobile apps weren’t showing the training plan. They did fix that and that is solved. It seems that if you re-enrolled while the bug was hiding the plan, you effectively started a new one, overwriting the progress on the previous one. I would definitely see what Zwift can do to revert it, but I don’t think this is the thread to do that. Maybe start a new one based on the re-enroll problem or contact support directly, if they haven’t reached out already based on these replies. I hope you can get your progress back!

2 Likes

@Damon_Gunther I kindly disagree. For a short while there, the suggestion from Zwift was to re-enroll and just continue doing the workouts. Also, this ‘second bug’ is fully caused by ‘the first bug’. Its a consequence of the original issue, not some other slightly related issue. It’s inexorably linked to the bug pointed out in this thread.

When fixing software issues, there are three steps that need to be made. (1) Identify the issue and fix the root cause. (2) Make sure that any damage done due to the bug is fixed, reversed, or compensated. (3) Put in place tests and procedures to make sure that the bug isn’t repeated in subsequent releases.

It appears that Zwift is still on step 1 of 3 (all though we won’t see anything on #3 until they either come out and tell us they’ve put in measures to prevent this same thing in the future, or until the next update(s) roll out over the course of the next couple months.).

Zwift still needs to address steps 2 and 3, and the best place to do that is to respond here on the forum where the original issue was brought to light.

Imagine if you will, that a till at the ATM spit out only $10 instead of $100. When you told someone, they went and fixed the issue so that it handed out the proper $100 instead of $10, then closed the ticket and said “go ask compensation/repayment/restitution somewhere else”. That’s kind of what is going on here. That’s also why people are kind of upset. They are out ‘$90’ and getting crickets from Zwift about making things right.

@shooj Do you have any updates on steps #2 and #3 on the above list?

3 Likes

Hi,
The issue has been partly solved but not completely. Hope the following lines will help to understand what is still going on.

Before new release publication:
I was following a training plan and did completed week 1, 2 and almost week 3. All the distance, duration, energy and Stars collected were fine. No issue.

After the new release has been published:
I have lost all my traning plan progress like I haven’t done any activites or even started the plan. All the distance, duration, energy and Stars were back to zero. I did NOT re-suscribed the plan as i was sure it was a bug of the new release that will be fixed. I did not use Android or iOS app meanwhile either.

After the patch has been published:
My training progress was back but only the done activities till the beginning of week 2. Therefore all the rest of the progress of week 2 and week 3 were still NOT recovered as it should be. The statistics of all week 1, 2, and 3 are STILL LOST as well.

I did an activity of week 4 as a test to see if it is correctly saved as well as the stats related. Looks like it is OK now.

In a nutshell after the patch’s install:

  • Done activites are still partially missing
  • Full statistics have still not been recovered
  • Activites and stats done after patch install are correctly saved

I supposed that indeed the patch that has been published correct issues for some zwifters, but surely not for everyone.

Thank you for your understanding.

How can I download version 1.31.1, that fixes that training plan progress bug?

It was a release for computers and it should automatically download when you open the app.

1 Like

I lost my Gran Fondo progress and I still didn’t get it back. Do you know how I can do it?

Thats not really possible, if the game crashes while you are half way through a route you have to start all over.

That’s frustrating…I was half way through

I think he means the “Gran Fondo” training and not an actual Gran Fondo ride.

1 Like

Yes, that’s right. I lost all progress on my Gran Fondo Training Plan and couldn’t reestablish. Didn’t find this 1.31.1 version to fix it.

are you on a pc or mac?

I’m on a Mac. Downloaded the only version available but it’s not 1.31.1…it’s version 1.1.2!

That is the launcher version I believe. Not the app version.

1 Like

I have to admit that i am very unhappy with the whole update. Not only did i lose all my progress in my trainingplan but i also have massive issues starting the game, finding the smart trainer and loading into the different worlds…im really thinking about changing the programm to other offers… stop trying to work with a old programmcode and develop the game all new…u will always cause problems if u continue update a too old codecore…very sad to be honest

3 Likes