Losing Ant+ connection

Hey,
I have been on zwift for several years with no issues until recently. My setup is a Wahoo Kickr Core with zwift running on my Macbook Pro. I have an Ant+ USB dongle with an extension cable that is located close to my trainer and bike. My setup has been functioning fine for over a year and I have not changed anything. Sunday, as I entered the pen for the Tour of Watopia stage 1 race Zwift said that I “lost connection” in the upper left corner where the power and HR usually displays.

I changed the Ant+ dongle, the battery on my power meter, checked that the firmware was updated on my trainer, and powermeter, and still no joy. If I reboot my Mac or unplug my trainer and replug it, Zwift will repair for a short time but will lose connection. I have tried using just Bluetooth which seems to work for a bit longer but is still unreliable. I do not think it is the just trainer as the problem affects my powermeter and trainer pairing. Sufferfest app seems to work OK. That makes me think that it has to do with the zwift program. I ran my log file through Zwiftalizer and it did not reveal any Ant+ drops.

What other troubleshooting options do I have. I need to get this fixed as my team needs my points in Tour of Watopia.
Thanks

Have you changed any electrics nearby? New router, extension cable etc moved the power supply to the trainer etc? I plugged in a stereo nearby to my trainer and caused no end of issues, no idea why and took me ages to find the issue

Hi @Ralph_Moore_EXN_C

Welcome to the forum

This mean that there are probably some interference as Dappy suggested. The lost connection message is new to Zwift so you may have had issues before but you just did not know it.

Faulty extension for me. Never had a dongle fail but 3 cables and they can do exactly as you’ve described.

Thanks for the input, team.

@Damon-Parker there is a wireless access point in the room but it has not changed. I am looking to make sure that it is not on a wifi band that would interfere. Will post results.

@Stuart.Middlecoate I have ordered a new cable, it will be here tomorrow. Will let you know.

Thanks for the advice.

Update, the wireless AP was using channel 8 whichh could interfere so I changed the channel. Will check and see if it helps