L'Etape 2020 - iOS crash

Hi @Paul_Evans64

Welcome to the forum.

You can put your log file in zwiftalizer.com and look at your fps (frames per second). I would gess it went really low and the pc could not keep up.

2 Likes

Avoid large events.

Same for me. iPad running iOS 12.4.6. Crashed at the beginning of the stage and then as I crossed the line.

Hi. Yes, hdmi from tv to laptop. But I’m not running two screens, the tv is showing what is showing in the laptop (hope that makes sense).

In the past I’ve had tv to Apple converter thing via hdmi and then converter thing into iPad and it’s always saved an image.

S

To use an analogy think of the Zwift screen as a deck of cards. Each avatar is a card. Now simply by moving with other avatars you’re shuffling that deck, which takes effort. You’re also replacing some cards with others at the same time.

That’s fine for free riding, where you may have 10 cards and swap/shuffle a few times a minute.

Now Zwift can display 100 avatars on screen at once e.g in the pens. Essentially 2 decks of cards.

Now, with that 2 decks try constantly shuffling them while at the same time swapping 10 of them every second or so. Not so easy.

That’s essentially what the Etape does. The better the system the more and faster hands you have. :slight_smile:

Update: good news / meh news / good news

  1. Later this week, we will retroactively award the L’Etape 2020 kit to anyone whose game app crashed. No need for you to do anything except to have the latest game version.
    You’ll need to go into the “garage” and select the kit.
    I’ll post another update after we finish awarding your kits.

  2. Low-memory iOS devices may still be prone to crash if you use them in this coming weekend’s final stage of Virtual L’Etape du Tour. We advise you to play on a laptop, Android device, or AppleTV if that’s an option.

  3. Thanks to all those who took the time to send in game logs, we were able to identify a root cause and we’ll make improvements to reduce the risk of low-memory crashes in the near future.

1 Like

Wanted to follow up to those using MacOS devices as well.

Thanks to @IDS sending in his crash log from his well-spec’ed Macbook Pro, we determined he suffered a cache crash, which is a different issue than the iOS crash.

For the MacOS users on this thread, please follow Ian’s successful resolution:

  1. Confirm only 1 instance of Zwift is running. Multiple devices logged in to the same account can cause a ton of issues, including this one.
  2. Clear the Mac cache.

If you want to be super-cautious:
3. Uninstall the Zwift app. Using Mac Finder, search “Zwift” and delete all remaining folders and files. Then reinstall from scratch.
FYI step 3 will remove your in-game preferences for things like trainer resistance setting, music preference, default display settings, etc. so you’ll have to twiddle those knobs back the way you want them.

This seems like a scenario that Zwift could easily prevent.

Already working on it, actually. Would love for this issue to go away as soon as possible, but closing one door opens others. Planning for those consequences requires thoughtful discussion.

Wouldn’t they need that visibility to be able to offer the family or multi-user per account solution hinted at in the Zwiftcast checks notes two months ago, to check/verify correct usage? I guess that’s not anywhere close then.

Lukas - Fair question! We use a variety of internal tools and popular third-party tools to analyze issues. In this case shooj just chose one of them.

And your comment about “perpetual beta” or what-not is not without merit. We are trying our best, and have been hiring and training more awesome people to help us, and help you.

We appreciate your feedback, and understand your frustration.
Thank you for the candid feedback.
Will

Thanks for the reply, and it offers a glimmer of hope, but actions are more meaningful and there is some very low hanging fruit your new awesome people can start with. Fingers crossed for next update.

2 Likes

Good news about the fixes and fingers crossed for this weekend! The killer last weekend was around 30km in I reached Level 10 (+100,000 drops), game crashes at around 42km… manage to restore the ride and complete the event but drops have disappeared :frowning: Raise the issue and told nothing can be done… feels very demotivating and seems like a simple thing to add some digits to an account? Would be quite happy to drop back to level 9 and go through the pain again as not to miss out on the drops… has anyone else had this issue?

I have had it crash twice yesterday on my MacBook Air and it crashed 3 times for my wife on her MacBook Pro. Everything is up to date with latest versions. Each time within 30 seconds of go.
Fine in other worlds before and after. Fine at the start line until the flag drops.

Three of four events on the L’Etape, Zwift crashed. On the first leg, I was able to log back in, and it sort of dumps you on the course, and starts you again at 0 mileage (which is why you see all sorts of people on the course with different mileages, even when they are at the same point in the race). Stage two seemed to work fine. Stage 3 two days ago, crashed, and I could not log back into stage 3. So I tried stage 3 AGAIN yesterday, and same crap. I finally was able to get through it last night. I just TRIED to do stage 4 just now (2pm PST on July 15), but it crashed FOUR TIMES during the event before I was even finished my first lap. Each time I was able to get back into the race at some random spot, but finally after the 4th time Zwift crashed, I could not bet back in, so I just rode around pissed in NYC…Please fix this Zwift…

Same happened to me today. so pissed off with it and tried it twice and both times it crashed on my MacBook Pro. I was trying to do TDF Stage 4 but every time it quit unexpectedly. Please fix this issue!

I’ve had the exact same issues. I’ve been riding both L’etape de tour and the vTDF Discovery rides and the same thing has happened every attempt now. I get about 1,5 laps in and then it crashes. It doesn’t even save my data so I can manually log my rides into Strava. This is super annoying and It seems to me like it’s pointless even trying to ride the new worlds.
I’m running Zwift on macOS Catalina 10.15.5.

I have had it crash on me twice In two days just as the timer hits 0.00 at the start of the discovery ride stage 3, using a MacBook Pro

Hi,

I’ve had the same issue on my MacBook Pro… Cleared the Cache, joined the event at 1pm and it worked ok although I only stayed in for 10 mins to see how it went.

Kev