Language settings now in Japanese, how to change

Hi, my language settings of Zwift/com are suddenly on Japanese. How can I change it back to English?

Restart Zwift. When you get to the device pairing screen click on the lower right where it says 日本語 (Japanese). You should then be able to select English as the language.

Thanks, but I mean on the website, not the app.

In that case click on the Japanese flag in the top right, you should then be able to select the region and language.

There is no Japanese flag unfortunately

The other way to change the location is click on the hamburger icon (top right, three lines one above the other). Scroll down and just below your name there should be a region selection option.

I’m not sure what is going on with your system though as the top line is in English while the rest is in Japanese. When set to Japanese the top line wouldn’t be in English. I’d recommend doing a “hard refresh” (google it for your particular browser) which will clear out any cached items and reload the page completely.

There is not unfortunately:
Schermafbeelding 2022-05-16 om 12.40.16

I will try the hard reset, thanks!

Still doesn’t work unfortunately. Bug in the website?

Try to login (first box is your email (Eメールアドレス), second box is password(パスワード) and see if the website still looks the same or if there is an option to change your region. If it’s still the same then I’m sorry but I’m out of ideas.

1 Like

Actually, there’s one other thing I can suggest. Check the address of the website. If it’s then you will get the Japanese login. If you change the “ja” to “eu” you should get the English login page.

Hi @Max_Dannenburg welcome to Zwift forums.

Shuji at Zwift HQ here. I see that you’ve already tried clearing the cache for your browser, and that didn’t fix this issue. Which is your preferred browser out of curiosity?

Does it happen if you use a different browser? If no - wondering if there may be settings differences between the two?

1 Like

Thanks! This did the trick. Strangely, my browser directed me to the Japanese version.

1 Like

Tried it on Safari.