Logged into Zwift.com this morning and it's all in French

Not sure if this is just me. The flag is for USA top-right, but the site is all in French.

It’s not only you. I had the same issue already a few days (or weeks?) ago and again today. Seems to only happen with certain languages. Maybe it’s Zwift’s new effort in not only stimulating our muscles, but our brains as well? :joy:

Experienced a similar issue. See here.

Weirdly it’s working fine now.

It seems to remember the last language set regardless of what is shown as the flag icon, so if you do something like follow an event link with a different language code, the language will change accordingly (minus whatever gaps there are in the internationalization) and it will also be used afterwards if you go to the site directly.

btw, I think it does not occur with Firefox… strange.

It’s all resolved now, very odd.

I hadn’t ridden in any international event, although I did ride the TGV route in France!

The event can be whatever, it’s just the language code in the event URL that matters. Looks like the event pages themselves are not affected but your personal feed is.

Repro steps (repeat in this order, at your own peril):
This is still in English: 3R LaGuardia Super Sprint Race - 1 Lap (3.7km/2.6mi 27m)
Maintenant en français : Workout/Training Session Complete! | Zwift
Back to English, eh: Workout/Training Session Complete! | Zwift

So English or… French?

Disabled Chrome cache, refreshed - same. Switch to Japanese and back - still the same. Firefox - OK.

???

@B_CN

Thanks for letting us know. I’ve let our web team know that this page is acting up.

8d an going, and the issue is still there.

Common, Zwift, you can do better.

(Switched to Canadian English, because, apparently, English is difficult in California)