Kickr snap erg and power meter problems: is it my setup?

Hi, i use a kickr snap. tri bike and road bike. sram and shimano. changing cassettes let alone thru axle bikes … ugh. not to mention the kickr snap is roughly 1/4 the cost of the kickr. i don’t need more than 12% slope support as i don’t have the watts to do 16%+ grades anyhow without using really non-world gearing. but i need erg to work and when it’s set at 100 to do 100 watts + or - 5% … not 25%.

is it my setup?

i have wahoo powerlink pedals dual sided. in the wahoo app i don’t have Ant+ connection turned on for those pedals. nor do i have erg power smoothing turned on (tried it … no difference). i connect to my mac mini running zwift over bluetooth. not using the zwift companion app. i connect the kickr snap first. then go to power source and change that to my powerlink pedals. then i go to custom for workout and select my training peaks interval workout that my coach set for me. that workout has power set as ranges of threshold power. zwift sees it and loads it.

i start the workout. but then i have to switch zwift to erg mode. is that normal or is there a place to set erg to stay on by default and is the fact that it’s not on when i start the first warm up section why it goes so much higher than the watts range set in the workout plan? i’m trying to ride at say 80 watts but it won’t let me get below 100 unless i switch gears and then it ramps back up after 10 seconds or so. it’s setting the power that that 100. i tried to ride that same flat course with erg turned off in that workout section. i was able to get power lower… 60 watts for example with terrain and gearing. so why isn’t erg working to do the targeted 85 watts?

once i get past that first interval and get into the next ones that feature 145w for 3 mins, then 80 w for 3 mins, with erg turned on before this interval started you can see it try to get to the 145… i still have trouble when it comes to the recovery interval though right after the 145w where the target is 80 and the trainer is doing 100 and going up and down. the grph of the watts is a jagged up and down.

any ideas? is it that erg isn’t on when the workout starts? is it that i’m not using Ant+ connection between pedals and trainer and then selecting trainer as both controllable and power source? any ideas?

thanks :slight_smile:

Since no one else has chimed in yet, I’ll offer that I think you need to connect the Snap as your power source, then make sure it is also paired as resistance and cadence before switching your power source to the pedals.

1 Like