Kickr Snap 2017 - No Wrench Icon


I have a 2017 Kickr snap that I use with FE-C mode, and am having some issues with the power readings (they are about half of what they should be). I did a spindown in the Wahoo app, and am trying to do the same in Zwift to determine what the issue is. Per the website here:

It says that a wrench icon will be there if calibration is an option for my trainer. I do not see this icon, but my trainer is listed in the table at the top, connected via FE-C, and most certainly can be calibrated.

What am I missing? I’m about a ~250W average per workout cyclist, and my power in Zwift is fluctuating between 80-110W no matter how hard I am sprinting.

Any insight would be great. Thanks!

Are BOTH trainer AND power source connected via FE-C?


That was my problem, thank you Cleve! :slight_smile: I had the power source set to FE-C, but not the Controllable.

Appreciate it!

I does not work for me. Power, cademce, controllable are all FE-C but I don’t see the wrench icon no where.
Power is not calibrated at all.

I’ve got nearly the same problem. All connected by Bluetooth on the same WiFi home network. I just got my Kickr snap about a month ago. I use Apple TV for Zwift or my iPhone XR. When I use ATV, the Kickr connects and lets me ride but there is no wrench for me to do a calibration and my watts are too high. I’m usually a 90-120watt rider but am now averaging around 180. And my resistance isn’t changing on hills like it should. I’ve tried unplugging, replugging, uninstalling and reinstalling and nothing works. The snap pairs and calibrates (and controls) just fine in the Wahoo app so I don’t think it’s the trainer. Also, when I connect to Zwift through my iPhone XR, the wrench shows and I can try a calibration but it times out and fails. I am able to ride and the resistance does change like normal. So, it’s something with the Apple TV connection with Zwift and my trainer. My husband has the same trainer (purchased about a year ago) using the same firmware and it works just fine through ATV. At this point, I’m not sure what I’m missing!

Just use the Wahoo app calibration.

You need to calibrate the trainer. You do not need to use Zwift to calibrate.

I’ve done that and it will calibrate in the app but I still have the same issues in ATV (no resistance change and high watts). I’ve tried warming up in the wahoo app, calibrating, then moving to Zwift through ATV but it doesn’t fix the problem.

That’s frustrating. Maybe there is a single glitch behind both problems, behind both the unavailability of the calibration option in Zwift, and the lack of resistance changes across gradients in Zwift. It is odd that you have two of the same trainer and only experience the problems with one of them.

I suppose you’ve gone through every setting, one by one, to verify that each software and firmware setting is identical, but still get the problems with one trainer but not the other? And both of your accounts have the problem with one trainer and both have no problem with the other trainer?

It is frustrating. I can’t figure it out. Same trainers (Kickr Snap), same connections (Bluetooth to ATV), both trainers on the same firmware. The only thing I can tell is different is that one trainer was purchase about a year before the new one (maybe it’s “older” or maybe not). And we have different bikes on them of course. We haven’t switched which bike is on which trainer because I don’t believe that will make a difference. I feel like I’ve gone through every setting but please feel free to suggest something you think I’m missing! I appreciate your help and thoughts. I have a support ticket into Zwift but so far their suggestions are covering the same old ground and haven’t resolved the issue.