Kickr bike stuck at 119w ERG after leaving workout to race

Just got a Kickr bike and had a weird bug last night. I did a workout for a race warm up in erg mode connected by BT to a Win 10 PC. While I was in the cool down at 119w I left the workout and joined the pen for the WTRL TTT. When it was time to go the team sprinted out the pen but I found I was unable to get past 119w. Unpaired and repaired and still the same, unpaired and repaired with ANT+ and ERG let go by which time the team were nearly a minute ahead. That was the end of my race, bit disappointing - Just don’t want it to happen again

I’ve seen this on my StagesBike SB20 when leaving a group workout and going to a free ride. I had to quit the app to resolve it.

Just to follow up on this, it still happens intermittently.

Have missed another race due to this and very nearly missed the start of a race again since.
I now have to check I can get watts without erg when entering a race every time just in case.

Unpairing the bike and adding back drops erg when in the pen.

1 Like

I recently noticed that after finishing a workout, the buttons for steering, activating a power-up, and making a u-turn no longer worked on my Kickr Bike v1. However, the buttons for shifting gears did work. Perhaps this is a related issue?


I’m going to check mine later today as I saw that thread. Another thing Zwift broke in an an update.

Be nice if they’d implemented on screen gear display as per Atom Bike.

The holding onto erg has happened for me since I got the bike last October so not a new thing.

We are multiple users of the Kickr Bike reporting this issue after Zwift’s latest update.

There is a dedicated thread here : KICKR Bike Powerup and U turn buttons don't work [1.34] [April 2023]

I know, just thought the issue might be related (some kind of missing reset issue or alike).