Kettler treadmill target run speed - 0,2 kph in 101 training plan?

Hello all,

I am a Zwift beginner and completed the 101 training plan, and just started the 3 Run 13.1 training plan. The target speed of the first Tempo run was too fast for me, and I had to stop the treadmill to recover and resume with lower speeds. I noticed that that set the target speed to 0,2 kph. The same happened to some of my future runs; the target speed changed to 0,2 kph, which is obviously almost zero.

I tried to tinker with “edit paces” to set them to somewhat more reasonable paces, but the future workouts still show 0,2 kph target speeds.

Am I doing something wrong? I’m assuming user error on my side, but I can’t figure out how to ‘reset’ the training plan target speeds to something more reasonable based on my updated paces (in the public profile).

Thanks for your suggestions,


Hello @Paul_van_Gelder welcome to Zwift forums.

What treadmilll / runpod is sending the speed / cadence data to Zwift? If it’s a treadmill - we’d like to know the manufacturer / model / date of manufacture. The last bit is important to see which generation & possibly determine what version firmware is loaded.

The make / model / manufacture date is usually on a plate or sticker affixed to the treadmill. Would you check for us?

You can change your target paces in your profile in-game. They are what determine your workout target speed.

1 Like

Check that your times are correctly set as mm:ss or HH:mm:ss

1 Like

Hello @shooj Shuji,

The speed data is coming from the following treadmill (I don’t have a run pod):

  • Manufacturer / Model : Kettler / Alpha Run 600, part number TM1039-100
  • Date of manufacture : Unfortunately, the sticker on the treadmill doesn’t report the date. However, we bought this treadmill in December 2021, so it’s quite recent.
  • I checked the menu of the treadmill and it is reporting Software Version 1.22. Hopefully, that’s useful.

Please note that when I stopped the treadmill mid-workout, the Zwift app target speed changed to 0,2 kph. When I restarted the treadmill, the Zwift app measured speed was consistent with the speed set on the treadmill, but the target pace remained at 0,2 kph. It seems somehow that stopping the treadmill confused the Zwift app target speeds, not only for the workout but also for future workouts.

Please see also the pictures I’ve attached (one of a future workout for later this week, and one for my current paces).

Thanks for your help,


Thanks Jesper,

Please see also my reply to Shuji: the target paces in my profile in-game look alright (although it’s slightly confusing to see all the grey "0"s in front of the actual times) but the target paces in the (future) workout remain at 0,2 kph.

Thanks again,


Hi Paul,

Some of your target paces are way off, judging by your attached image.

Your 1 mile time is set to 7 hours, 0 minutes, and 11 seconds.
Your half marathon time is 107 hours, 8 minutes, and 10 seconds.
Your half marathon time is 232 hours, 9 minutes, and 29 seconds.

If I was you I would correct these and then everything should be much better in the workouts.

1 Like

Hi Jesper,

That seems to have fixed the issue in my future workouts, many thanks for your careful review and suggestion! (I somehow read those times as 7 minutes, 107 minutes and 232 minutes.) Still not sure what caused the reset to 0,2 kph in the first place, but after correcting the times the new target speeds seems much better. (I’m hoping the 5k run that’s later on in the training plan will set these speeds to something more accurate, but this is good enough for now.)

Again, thanks a lot for your help,