Jetblack Volt EMS

Hi from spain.

Today i bought the trainer Jetblack Volt EMS.

I have connected by bluetooth and all worked fine. But every 8-10 seconds the device appear in disconnected mode. Then, wait 8-10 seconds and repeat the problem.

I tried all the tyipical steps to solved, but any can be solve my problem:

  • restart the computer
  • try with other computer
  • connected to other wifi line
  • power off devices than can be created a problem in the Network

Any solution? I tested with +ANT protocol and same problem.


Hi @Josine_Gonzalez_Aceb, welcome to the forums!

Firstly, if Zwift Support team were responding, they would suggest you to try troubleshooting following the guidance in this:

BLE and ANT+ Interference Troubleshooting Tips.

I would also suggest you grab an activity log file where you have encountered the problems and drop it onto to see what it reports with packet drops - you can share a link to the report here if you need help deciphering.

1 Like

Hi Josine
I use a JetBlack EMS with zwift, so far I have had ~2000km of trouble free running.
Have you set the trainer up using the Jet Black App?
The trainer does need an initial setup, and a periodic approx. monthly zeroing cal is required firmware updates are all done through the JetBlack app.

You can download the JetBlack App for IOS and Android.

If you cant get reliable operation using the JetBlack app I would suggest that the trainer is faulty.
I have found JetBlack support to be pretty helpful.

1 Like

Thanks a lot :slight_smile:

I will try to catch the logs with this tool to see the real-time graphs.

Yes, I configured the device with the JetBlack App (in my case, the Android app). Using this app I didn’t have any problem and the Watts value was perfect, without disconnections.

This is the strange, the problem is with zwift only.

Hi Josine

I suggest you look at MySettings/Settings/Power Display in Zwift…I run 3 second average not instantaneous.

It may be worth trying.

Good Luck!


1 Like

Hello @Josine_Gonzalez_Aceb welcome to Zwift forums.

If the signal is lost this consistently - it could either be another app is stealing the trainer’s Bluetooth signal, or that you have a noisy room for RF signals interfering with BLE>

It is possible that the JetBlack app is stealing the trainer’s BLE signal. What happens if you uninstall it?

1 Like

Funnily enough, exactly the same thing has started happening to me with my Volt.

Basically, it will connect via Bluetooth or ANT then when I start to pedal the connection drops and then reconnects. It continues doing this but There isn’t any resistance on the trainer so I just gave up.

It was absolutely fine yesterday. The same thing happens when I connect it to the JetBlack app and also my Garmin bike computer.

It looks like a hardware issue and I’ve reached out to JetBlack for some assistance.


Thanks all for the help, it’s great that Zwift has this community :slight_smile:

I have good and bad news. The bad news is that I changed the room, configure the device in Zwift’s settings, and uninstalled the JetBlack app and the problem still exists.

The good news is If I connected the device with the Zwift companion app and then uses this connection on my PC, the problem disappeared.

It’s so strange, but it is a solution (meanwhile I created a case on JetBlack website)

Thanks a lot for the help guys, we see on the road :slight_smile:

1 Like

@Josine_Gonzalez_Aceb did you ever find a resolution to this problem? I just purchased a Jetblack volt and its really frustrating to have your ride stop so regularly.
Is the solution you found to connect the Jetblack to the companion app on your phone and then connect your Pc to the companion app? How do you go about doing this? This is my first experience of “zwifting” so this all sounds very complicated to me. Any guidance or instructions would be greatly appreciated.

Hi @Richard_Worrell .

Yes, this workaround solved the problem (But it’s a workaround, not a good solution) I’m very disappointed with this purchase. I tried to refund the package but I recycled the boxes and the third party can’t return the product.

Anyway, I can explain the steps (I am not a Zwift expert, maybe other Zwifter can be explained better).

1- Download the JetBlack app. Configure your device. Uninstall the app to don’t create more interferences between Zwift and JetBlack.
2- Download Zwift app Compain on your mobile. Enable Bluetooth and add the device in the Bluetooth settings page.
3- Open Zwift app (in my case on my PC) and change the connection between the PC to the Zwift companion app.

For me it works, but the ERG doesn’t work correctly.

If you can, in my opinion, you should be return the device. It’s a very bad purchase.

I hope that this message can help you. (Sorry for my English, I’m from Spain :slight_smile: )

@David_McCormack I’m having this exact issue now after nearly six months of my Volt working perfectly fine. It’s so frustrating! Connects when stationary, but as soon as the cranks start turning the Bluetooth light flashes all the colours and drops out. Did you ever find a solution? Did JetBlack support manage to help?

Hi Lionel,

I still don’t have answer for the support. It’s to sad that i spent more than 500 euros in this device and we have a lot of issues.

And now they’re getting sued by Wahoo–they might be less likely to respond than before.

Yes they were really helpful.

It turned out it was the power brick. I got a new one under warranty from the retailer but I also bought one for the right voltage from Amazon and it has been perfect since I started using it.

Hope it’s the same thing for you as it’s a really easy fix.

Thanks @David_McCormack that’s really helpful! Do you happen to have a link to the power brick you bought?

I do indeed. It was called Gonine 19v 32A Laptop Charger and I still use it over the JB branded one I got under warranty.

You are looking for a 19v adapter and I went for multiple connectors as I wasn’t sure which one fitted it.

I wish you ever success. I was sceptical that this was the problem but as soon as I plugged it in and rolled the flywheel it was back in business.

1 Like

A word of caution to anyone in this thread: from the reviews I’ve seen posted by DCRainmaker, the JetBlack Volt and Zwift hub come with an external power brick that has three prongs. (power + ground)

A lot of these aftermarket, “universal” bricks are two-prong, ungrounded. I’ve attempted to use similar with laptop docks in past and it resulted in premature failure of the dock.

I’d appreciate it if someone with actual electrical engineering degree could weigh in on this.