ISP or CDN issue with latest v1.0.52 files - Z117 at line 601 in Patcher.cpp?

Yes, I tried to do everything. I reinstalled 3 times, removed the firewall, used another network for the download. But without getting anything

Same problem today: on the last update (march 2023) i ve ha the z117 error:

I use a smartphone as hotspot and i know that with another connection it will run correctly but at the moment i ve no other connection avaiable

I run it as administrator
i don’t use cloud sync app like google drive or similar

Since the update is mandatory i cant use zwift until i’ll connect my pc to another ISP in another house…

Can someone help me???

Exactly the same experience here.

Was on Vodafone landline via copper wire. No issues updating (though slow internet connection).

Can get better speed via 4g so switched to 4g home broadband with a Vodafone SIM in the 4g router.
Suddenly getting errors in download and failures. Logfile says file download fail due to either checksum or length errors (and a lot go gobbledegook I don’t understand).

Tried tethering to phone instead (which is on o2). No issue with download from o2.

So definitely a Vodafone-Zwift interaction issue in my experience. Going to ask ISP (National Broadband, UK supplier) for an o2 SIM for the router.

…so this still isn’t fixed!
Though I still use Vodafone mobile broadband, I now use a VPN and have not seen this issue since, when using a VPN.
There is definitely something contained in the data (of large updates, if not small updates) which MOBILE Vodafone does not like and truncates the download.
A VPN to hide/encrypt the data content has worked for me ever since first seeing this problem.

1 Like

Thanks. That’s good advice. I’ll try that if the broadband company won’t give me a SIM for o2. Don’t like Vodafone for lots of other reasons as well.

I think iCloud private relay is a form of VPN which is an easy switch on if you have iCloud+ and a Mac.