Is Tri Academy actually working?

So I have attempted 2 runs (1 failed due to problems between my Stryd and Apple TV) and the other was successful. However, Tri Academy had me completing 3 runs! Well I deleted a whole bunch of 0 effort runs and now Tri Academy has me completing 1 run - good - but has identified it as 6x800 instead of the VO2Max Development which was the one I actually did. Is it going to matter which runs I do to try to complete the run component given Zwift can’t seem to keep track of what I am actually doing!?

Look at you progress using the Zwift Companion App. You will see a correct listing for your efforts. In game, it seems that if you do the last running workout not in sequence, it considers you to be finished with all of them, but the ZCA has a correct tally.

1 Like

the list is not correct. doin other workouts than in the list. look here: Tri Academy Completion

Thats the problem - the companion app is NOT listing the correct activities (number or even type). When I started it had listed 2 activities when I had completed none. Its like it is just randomly allocating effort. My Zwift profile of activities completed is correct and it does not match the Companion App list.

Mine is doing the opposite. My in game count is wrong but my ZCA is listing the WO and races correctly. Based on what folks are saying, sounds like there are numerous problems. I’m just making sure I document the activities and will submit a ticket when all done if I don’t get credit for the activities.