iPhoneX taking over bluetooth signal of Wahoo Kickr from Apple TV


(Jason Mak) #1

This is a problem that all of a sudden came up - I have a problem where I can connect my wahoo kickr (via zwift) to my wahoo kickr while I’m running zwift on my apple TV.  However, as soon as i turn on the bluetooth to my iPhone, my wahoo kickr jumps over to the iPhone and my avatar on zwift stops pedaling.

Worst is that i don’t have a “forget device” or “disconnect” device on my bluetooth menu for the kickr.

i suspect at some point i was running zwift on my iphone but i shut that off too.  but for some reason my iPhone still overtake the bluetooth signal from the kickr…anyone have any experiences with this?


(Paul Allen) #2

I think a simple solution would be to keep BT off on your iPhone.

I didn’t see anywhere that you are using the iPhone to bridge any BT devices to the ATV.


(Jason Mak) #3

Thanks Paul - that’s what i’ve been doing but the reason i started turning on the BT on my iPhone was so that i could connect to some BT speakers to listen to music…it’s weird, for the first few months it was working fine…

and you are correct, i’m not using iPhone to bridge any BT devices to ATV…(at least i don’t think i am…lol)

thanks again


(Paul Allen) #4

Within the ZCA under Settings>Sensors you can disable Bluetooth LE sensors to see if that helps.


(Jason Mak) #5

sorry Paul - what does ZCA stand for?


(Benjamin Bishop) #6

I agree with Paul, turning off BT is definitely the simplest solution. 

ZCA stands for Zwift Companion app, previously called Zwift Mobile link. Which has the ability to connect to the trainer. You also might want to check to make sure no other apps, on your phone, are trying to connect to the trainer, such as the Wahoo App.