iOS Companion app 3.29.0 (1158) issues [SOLVED]

MeToo… hope it will be fixed soon. Maybe a roolback to previous version, could fix it…


Thought it would have been sorted by now. Obviously got other more important issues to sort out first.


I contacted Apple yesterday regarding that I pay for something that does not work as they should. They were so interested in this that they called me. They seem to take it seriously!
Therefore, urge you who pay via Apple to contact Apple to show your dissatisfaction!


Thank you.
Today I opened Zwift on iPad and ran Companion on iPhone. The companion map loaded.
For me anyway, the issue seems specific to Companion app on iPad not loading the map for approx 3 weeks

Appreciate the efforts


I have the problem with my iPhone and iPad since the last update. They don’t connect to the ride. I hope we could go back to the previous version. :pensive:

1 Like

Posting to subscribe. Same problem as everyone else. Companion on iPad.

Yes. Cannot us Companion App at all still. Been 2 weeks

1 Like

Same issue! Connection to companion on my iPhone 12 works but not on my iPad just contacts and drop after 1-2 sec. Same iOS 15.1 on both same companion 3.30 but just works on the phone?

+1 I’ve had all the above issues, blue screen, white screen, map, on the latest iOS on iPhone 10s. Very intermittent though, rebooting the phone and killing the app 1,2,3,random times works

Same issue here - Ipad v 3.30; map switches off after 1 second.

Hey ZWIFT so what is the answer here? When will this be resolved. A lot of us use an iPad for companion and a Apple TV for Zwift in group rides. Using the phone? too small. And it also has a problem where the map won’t appear. When will this be fixed?


@shooj Any update? Ipad opens Companion but map of live status shows until circle around rider closes, then goes off screen. It’s been over 3 weeks.


Same, fine on iPhone, but experience much worse given screensize

Companion app works intermittently in-game now on iPhone, however Filter button in Events doesn’t do anything when pressed.
Is anyone else finding this?

iPad still not working in-game but filter button does work. :man_shrugging:

Is this really necessary? Shouldn’t you be advising that both systems are on the same network/subnet? I run zwift on a Windows 11 system that connects using Ethernet, no Wi-Fi on it. Until recently ZC worked just fine on an iPad using Wi-Fi on the local network. The applications shouldn’t care about whether it’s on a hard wire connection or Wi-Fi as long as the network/subnet is the same.


People need to stop posting things like “make sure it is on Wi-fi”. This is NOT a user issue. This is ZWIFT not getting off their a$$es and fixing a bug. It worked a month ago, now it does not. This should be a straight forward patch and it is REALLY ticking people off that they are not fixing it. How hard is it to ensure that the connection remains persistent. The issue is clearly theirs as the map pops up on the iPad and then it drops away. FIX IT ZWIFT FOR CRYING OUT LOUD.


Spot on Michael :+1:

Exactly, I’m sure if their billing system stopped working they would find the resources to fix it immediately :rage:


Steve - your comments are spot on. I run Zwift game over ethernet (Win 11) and ZCA over wifi (iPad OS 15.1) as well. Never have had a problem until this recent update broke the ZCA on iPad.

I wish people would stop filling the thread with complaints. It makes the job of sifting through the noise to find meaningful feedback very tedious. We have heard all of the threats of cancellation and whining about the length of time to fix. Enough already.

1 Like

EXACTLY. We are paying a monthly fee and if they couldn’t collect that? They would be all hands on deck.