iOS Companion app 3.29.0 (1158) issues [SOLVED]

Bob, what is tedious is the lack of ZWIFT providing any feedback on when they will resolve the issue. Unfortunately with things like this, the squeaky wheel gets the grease. Perhaps if more people piled on, they would actually fix it or start effectively communicating about the issue.

Rule number 1 of customer service is not being addressed by ZWIFT: acknowledge the problem. Even an answer of “we are working on it” and then regular updates provides people with a sense of being heard and then they can wait patiently.

Silence is never the answer.

There is no meaningful feedback left to give – all configs (ethernet, windows, mac, etc) make it clear, this is just broken.


Having managed an apps engineering group for a semi conductor mfg on a global scale prior to retirement I have a fair amount of customer facing experience in addressing product shortcomings. In my experience the squeaky wheel is left to squeak and the attention is brought to bear on those trying to help solve the problem.

For those that would rather harp on Zwift’s lack of hand holding I respectfully suggest that they suspend service until the problem is solved and that they negotiate (off forum) for a free month of access to be used when they choose to resume service.

Interesting, my observation is that I do not see people threatening to quit the service (I for one am not, I keep using it – this an element of the service – not the core service), I see them voicing frustration at the lack of transparency or communication on the issue.

As for those “trying to help solve the problem”, I would agree if any feedback in this thread actually contributed to helping solve it.

It doesn’t. It is just repetition.

A quick review of the thread will make it obvious that this is a highly replicable bug – as everyone seems to be having it (regardless of config) … so any additional feedback is pretty much useless. “help” is handy if they cannot replicate the bug and need multiple configs to figure out if it is actually a config issue … which it clearly is not.

So … back to squeaky wheel just trying to get them to acknowledge the bug, and let us know what they are doing … if anything.

As for me … I will try it once a week, while waiting for them to comment on this thread that they are actioning it.

1 Like

Not that this is an excuse for not yet having corrected the issue but, just so you are aware, Zwift DID acknowledge the issue. I think post 19 of this thread shows that (as well as the fact that this thread has been moved to the ‘known issues’ section of the Forum). There are also some additional comments from Zwift staff throughout this thread.

Again, the issue should have been fixed by now, IMO, but don’t mischaracterize Zwift’s response. And I’m guessing the entire response has been hampered by the Thanksgiving holiday in the US.

Thanks Nigel. Missed that.

Zwift, roll back to the previous, working version until you can resolve the problem! How many days now?


24 days,…one month just around the corner,… Unbelievable!

1 Like

I use apple tv 4k and companion app to zwift. Recently companion app has started closing as soon as I try to start a zwift ride. I can continue to ride but the companion app flickes into into dashboard mode but then comes out of it which makes it a bit hard to run. Here is a short video of the issue for clarity.

I have a video of it on YT but can’t link here of course…

Things I have tried.

  • Updating Apple TV and Ipad to current versions of software.
  • Updating to current versions of Zwift on Apple TV and current version of Companion App on ipad.
  • Turning modem and router off and on.
  • Confirming the AppleTV and Ipad are on the same wifi network.
  • I’ve also deleted both the ZCA and Zwift from the ATV and reinstalled.
  • No apple watches were used or harmed

Thanks in advance for any ideas.

So why not make their “billing system stop working”. I have cancelled my subscribsion, and won’t be back before this is fixed. But this is Zwift support in a nutshield, i’ve been with them five years, and they are never really listen to the customers. So in 16 day will my account wich now are named a trial closing down, unless they come up with a solution. Many good program out there, all of them let you train, not only Zwift.

Did you read through the thread? There is no solution We are all waiting for Zwift to fix this.

1 Like

Sorry I just thought I’d throw my experience in as another person whose suffering the problem and what i’ve tried to fix it.

1 Like

This is a very frustrating problem. I’m time poor so I’ll keep this short.
Windows 10 with little but Zwift on it. Iphone 6s. Companion stuck on either white or blue screen (10 mins +). Checked Wifi was the correct connection (it was) but decided to unjoin then re-join. Companion now goes. When I shift across to my team ride, it seems a bit jiggy but joins…later it fully stops pedalling though, and won’t detect the trainer any more. My ride shows up as Macro to Micro ride (what I briefly started on) NOT ZSUN RnR (which I’d been on for 20mins. ). This is the second team ride in a row that Zwift has packed up on. To say that I’m unhappy is a gross understatement.

As with other users, I am experiencing the Companion “Blue Screen” on my IPHONE 11 for extended periods. Seems to open when ever it feels like.
I have tried to uninstall and re-install. Immediately after re-installing the Companion App, it opens right away, just once, then back to the extended wait time. All functionality seems to be there when the App finally opens.
I use an IPAD Air 4 to run the game and it seems to be working fine. Fingers Crossed.

Did the new patch today help? Wont get to try until the morning

Add me to the “me also” list… It begs believe that the amount of people with the issue and zwift still hasn’t addressed the problem.


Launch Zwift on Win 10 laptop using Ant dongle for trainer/heart/cadence and start ride. Laptop shows ride and does not appear to have any issues. Start Zwift Companion on iPhone 8 iOS 14.8.1. Blank screen on ZC on iPhone. Tried deleting and reinstalling on phone. Same result of white blank screen. No Apple Watch. Once I end the ride the ZC returns to non-ride screens. It’s like there’s a bad web service call displaying a blank pop over the ZC app during the ride. The app will still attempt to buzz the phone for certain things.

1 Like

And me too!

1 Like

David, I tried this after the app did an update this morning.

No, it’s still broken :disappointed:


Same issue here, using Apple TV for Zwift run and IPad Pro for Zwift companion - map comes up and then defaults to Home Screen - ZC.appears to work on iPhone 12 - happening for about 3 weeks, wasted hours trying to trouble shoot - glad I finally found this post!…… DG


Hello @shooj is there any sort of timeline on a fix for this. It’s been a month since the Zwift Companion App has been broken…