Internet root of house causes interference leading to dropouts?

I have been experiencing Bluetooth as well as ANT+ (tried both) dropouts since I moved houses, and quite lost about what the cause is. The setup is the same and I did not have any issues before. Dropouts range from total ant+ dropouts and occasional dropouts of HRM, often resistance of trainer doesn’t work.

The only thing that I can think of is that in the new house, we have the bike setup downstairs, close to the incoming internet connection cable which is quite old. I believe it is called ADSL or VDSL. That cable is moved upstairs to the router/modem that spreads wifi around the house. I did one workout when we just moved in and were still on the neighbours’ wifi, no dropouts then. Since the wifi was installed, I have the issues.

I have tried disabling wifi on my MacBook and using ethernet, but this hasn’t fixed anything. Wifi we use in the house is 5ghz.

Would be great if anyone could help, let me know if you need more info

You could upload log files to (preferably from before and after your move so you can compare) and it will visualize the dropouts and help you understand how much worse it is. Internet performance will not be related to Bluetooth/ANT+ dropouts. More likely some source of interference is at fault, which could be related to 2.4GHz WiFi devices in the area if there are any, but all sorts of other things can also do it. If you have absolutely no 2.4GHz WiFi devices then you might also be able to shut off 2.4GHz on the router.

This recent video has some tips (several of which you have already tried).

Could it be that there’s router interference even though the main wifi is on 5ghz?

Internet performance is indeed not the issue as I’m on ethernet now and disabled wifi.

I’m afraid the logs are gone as I moved over a week ago. Analysing recent files gives not much info, basically telling me there are lots of dropouts with ant or able, which I know haha.

Possibly if the 2.4GHz radio is enabled, and worse if on a channel that puts its traffic close to the frequency of your short-range devices like ANT+. If the 2.4GHz radio is completely disabled I would expect that possibility would be eliminated.

Logged in to the router but can’t find a way to turn 2.4ghz off. Can only change the channel from auto to some standard. The 2.4ghz wifi is not seen when searching for wifi on my MacBook btw, so not sure if it’s even enabled.

This router works with extenders that spread the connection, the router itself does not have any wifi.