Intel integrated graphics gen 10 and 11

Try this from my post above:
I’ll try to make this brief…

It appears I now have Zwift working with no crashes!

I was using Intel’s driver updates, but Intel told me to use my laptop manufacturer’s updates (Dell).

In this thread, or maybe another, someone said to install x driver from March 2020. I didn’t have the same option, but I installed the Dell driver from March 2020, and this seems to have fixed the Zwift crashing issues.

Intel and Zwift don’t seem to care, and Dell discourage using out of date driver updates, but what I did works for Zwift.

I’ve done about 18 hours or more, across about 14 rides and everything has worked well.

1 Like

After being pointed in the right direction by Jesper I thought I’d post my experiences. For me, screen capture is an issue.
Zwift on my laptop screen capture takes <1s and file size is 400kb
Screen capture after projecting to large screen take 2-20s and file size is 2MB

I changed laptop projection to ‘duplicate’ vs ‘extend’ and screen capture is <1s (uses laptop screen)

I’m projecting to large screen via USB-c to dongle with HDMI.

Finally, in settings I changed ‘Image Uploading’ to ‘Never’ and the system no longer automatically tries to take a screen capture at 38minutes.

I’m happy as it has solved my problem and I can jump into races now. Thanks.

1 Like

Could be final solution?

Update 1.19.1 - November 18th
We’ve released update 1.19.1 for PC to address a crashing issue on launch. No other platforms are impacted by this issue.

  • Fixed a crash that would occur at login on some PC devices with Intel graphics cards.

If you encounter anything unusual with this update, please post in the thread below.

See you in Watopia, Ride On!

Randy thanks for your feedback. I’ve been having same freeze up. Just changed image upload to never and changed resolution to low. I was already set for duplicate. Hope it works for me. Thanks again.

1 Like

It happened again, right this instant.

Can’t auto save at least up to where the game crashed? It is a shame to lose your training every time.

Help please

These are the data from my computer:

Windows 11 Home
Display Intel(R) Iris(R) Xe Graphics
Driver version 30.0.100.9805
It would be nice for Zwift to constantly save the ride data, for example after every kilometer traveled, so in case of problems, you’ll never lose the activity carried out until that moment.

Thanks

1 Like

You’re posting in the wrong thread, which doesn’t help. This one was about the game crashing on launch, not an hour later.

Anyway your problem sounds like this: Crash mid game (PC) - #3 by Dave_ZPCMR

1 Like

Thanks Dave,
I have read your post, but it is now closed and I cannot reply from there.

So, my problem is not solvable?

I got a new PC and now I can no longer use Zwift for this reason? I do not understand. Will there be a way to update Zwift and prevent this from happening?

Sorry but I’m not very familiar with the forum. Do you suggest me to open a new thread?

Thanks again

Hi @Mauro_Vespasiano

I moved your post here to keep it on topic and so you can get more help.

1 Like

There is a problem with using Zwift on the integrated graphics within 10th and 11th generation Intel processors, which causes the game to freeze randomly. It seems like that’s the problem you’re having too, so Gerrie has moved your post and mine into this thread. In the post I’ve linked to are a few other links where people have rolled back their Intel display drivers and the problem has gone away. You should give that a go, because as far as I’m aware there’s no fix from Zwift at the moment. :+1:

1 Like

Has anyone verified if the very latest 101 drivers work?

Yes I have in the week before Christmas. Bought a new Lenovo laptop in october and had crashes all the time. Intel I5, 10 gen, UHD graphics. Installed the 30.0.101.1191 drivers released Dec 3rd 2021 and did approx 8 1-hour sessions since and a 3 hour run of ‘Just watch’. No crashes till this point. So slightly positive.
Currently I use Zwift as follows: ‘run as administrator’, screen: ‘windowed’, resolution: medium 720; laptop battery saver: max battery saver.
Did not check high grahpics yet.

Note: when trying to update, laptop told me I had the latest drivers (27.20.100.8729). I installed a tool from Intel: Intel driver and support assistant installer (DSA); (www.intel. com/content/www/us/en/support/detect.html). This detects the new drivers and have you install them.
2 note: the install warned me that this would override the ‘standard’ Lenovo drivers (apparently I have those); which i did; since then no issues with Zwift crashing yet.

Hope this helps for other people in this thread as well.

Ride on!

1 Like

Hi Brian do you know which driver you downloaded??

See here: Zwift Crashing/Freezing Mid ride - #378 by Peter_Gross

Note that this won’t work on Windows 11.

I am having your exact same problem with the same Lenovo laptop, will install the latest driver and see how it goes - thanks for the post

I did several rides now, some over two hours. With resolution on ‘high’. No freeze since I installed the new drivers.

Hi Christian, have you had any more freezing issues with your Lenovo laptop? I updated the UHD graphics to the one you mentioned and worked great for about 2 weeks , now it started freezing again mid rides( not all but most) , just wondering if there is anything else I can do to enjoy the rides. Im also connected directly through Ethernet not wifi.
Any help on this would be great.
Myriam

Check Windows hasn’t updated it for you in the background. You’ll need to roll back again if so.

how to check the background?? when i go to check my device graphics its still the driver I updated but not sure how to do it in the background

I think Dave meant during a normal windows update, maybe it was overwritten?

1 Like

Hi Myriam, my first thought is the same as Dave. Check whether windows did not install the old or other drivers as part of an update. Otherwise it is difficult to say why it does not work with your laptop. Since installing the dec 3rd drivers I did not have an issue any more. I run the app on high resolution.
I do still run the app as administrator and have the laptop battery saver mode to ‘max battery saver’. Maybe you can try that. Otherwise I have no clue.

Succes, hope you’ll find a solution.