Intel 945 chipset, acer aspire 5630


(Holger 1980) #1

I would like to run Zwift on my Acer Aspire 5630. When I was using the Trial Version some weeks ago on it with the win 7 32-bit edition. That worked fine. Some days later, I was told, Zwift was not supporting 32-bit any longer. So I made a complete new systems setup with Win 7 64-bit.

When now starting Zwift, after log-in screen, I am told, my intel drivers would appear quite old and zwift may not function. I then can choose to visit intel website. If I choose no, nothing happens.

But the drivers I installed are the latest from intel. And as I said above - all worked fine before.

So what to do now?


(Frank van den Berg(ODZ-C)) #2

Maybe it’s the video driver wich need updating?

I had the same problem as you, changing Win 7 32 to 64-bit.

After installing the latest video driver, everything worked fine.


(Holger 1980) #3

That’s what I did. It is already the latest driver I can find on Intel Homepage. Unfortunately they don’t provide the actual INF-File there but an installer (exe). But I installed that and searching newer drivers has no result.

Any ideas?


(Holger 1980) #4

Anyone?