Incorrect Zftp and Category classification

Hi all, I just tried to enter a race for the first time in a while and shock horror, as a previously D Cat rider, I am now only allowed to enter Cat A races!
On looking into why, my zFTP is incorrect at 279w. All peak powers are dated and time-stamped the same date and time but looks like an erroneous activity to me and there is no activity listed at that time in my Zwift account.
The timestamp is just after an activity (ramp test) I did on Trainer Road but even then, the zFTP is impossible as my ramp test had me at 164w on that day with a max power of 261.

I redid a ramp test in Zwift this am where i hit 200w ftp (about right for my current training level) but alas, it did not update.

Has anyone else had a similar experience and found a solution?


Contact support. A ramp test will not reset your zFTP, which is just a magic number used for race categorization. It’s not your FTP, despite the confusing name.

A zFTP of 279W while weighing 70Kg doesn’t put you in A, because that’s ~3.98W/Kg and the threshold for promotion to A on zFTP is >4.2W/Kg.

Which leaves us with a zMAP promotion to A, because you (or someone using your account) have done an effort which suggests you can do >5.2W/Kg (364W) for 6mins.

What does ZwiftHQ have for your zMAP at ?

Please send a E-mail to

When you do, come armed with some information so that we can help you more quickly and easily:

  • A link to your ZwiftPower profile
  • Your ZwiftPower username
  • Your Zwift ID

If you aren’t sure how to locate your Zwift ID, check out this article for steps.

Do not post that information here. Please. Send it in the email.

Just wanted to share that we identified the issue (a rogue power output from my Assioma Uno) and the Zwift team have swiftly solved by deleting that activity (I had already deleted frommy Zwift account but it stayed on the server!). Thanks to the team for fixing this so fast. Now let race my way up to Cat C and beyond;)


Good luck Stu.

1 Like