Inconsistent/incorrect distance elevation


(Chris Jones) #1

Sorry if this has already been covered guys, I looked around and didn’t see anything exactly like this. When I select a course with set distance and climbing, it changes as I am on course. I’m not selecting arrows or turns in-course, just sticking to the route. For example my route today said 15.x miles and 550 ft of climbing or something around there. At 17 miles I already had climbed over 1000 ft and the ride still hadn’t ended yet. Am I doing something wrong? Something need to be calibrated again, etc?


(Kevin) #2

The distance quoted is for the lap. The ride does not end when you finish the lap, you just keep going.for another lap. You also start before the lap begins so there is some extra distance/climbing from that as well. An extra 500 feet in a mile seems excessive though. What course were you on? Are you sure of the miles/elevation?

Can you post a link to Strava for this ride and it should be obvious if what I said above is the case.


(Chris Jones) #3

Kevin it was one of the London loops, I can’t remember the name. Im not sure if my rides are saving to Strava or not, I’m still new to all this so I’m not sure how to see.


(Chris Jones) #4

Just checked my Strava and none of my Zwift rides have been uploaded apparently.


(Mark) #5

Same here. Today, it showed the Greater London Loop at 281ft (its about 580) and the Greatest London Loop at around 500 (that’s about 1000).


(Chris Jones) #6

Mark it was the Greatest loop that I rode, and it was ~1000 like you say. Wonder what the deal is, glad it’s not just me.


(Mark) #7

Happened this AM in Richmond too. It shows 257ft for the 2015 UCI Worlds Course.

In the slight chance support reads this, my set up is:

Apple TV 4k and the Companion App. Both were updated to the most recent version.


(Gerrie Delport TeamODZ) #8

Thanks for posting the Picture, now I also understand.

Your game menu show 257ft of elevation gain but the strava segment (see below) show 467ft.


(Mike Lister (DACE)) #9

I know this is an old post but I had a similar issue over the weekend. The Gotham Grind route is shown to have an elevation gain of approx 96ft, but when I rode it in an event it was over 300ft per lap. So it seems like this issue still exists.

Here is the segment - https://www.strava.com/segments/19749967

This is the event I entered - 54m of elevation gain quoted - https://www.zwiftpower.com/events.php?zid=152005

This is a screenshot of the elevation Zwiftrecorded over less than 1 lap