If your Ping time is higher than 50ms, it’s likely you'll experience performance issues


I’m currently trying to optimize any network/connection issues, and found this:

If your Ping time is higher than 50ms, it’s likely you’ll experience performance issues.
here: support[.]zwift[.]com/en_us/riders-disappearing-or-going-off-course-HJRjcp2GS

According to this test: zwiftalizer[.]com/ping
I have an average 195ms ping and 400 max

The issues I’m experiencing during races, is delayed power and surging out in front of the blob, and then being sent out in the back, to then have to catch up again over and over… Which is kind of unfair in a race if you ask me.

Are there any plans to address this issue, with European based servers perhaps in the near future?


You’re mixing up two separate tests. The Zwift support page specifically refers to an ideal ping test result below 50ms in one direction to a Los Angeles server via speedtest.net. The Zwiftalizer test is a round trip to AWS in Oregon, so the results cannot be directly compared. For example I just tested on my laptop (not my primary Zwift PC) and my Zwiftalizer result is 181ms average. My ping to Cloudfare’s LA server on Speedtest.net is 17ms.

Your average on Zwiftalizer is in the expected range.

Okay, did a test on Cloudfare’s LA server on Speedtest[.]net and got 32ms, which is acceptable.

Thanks for clarifying.

1 Like

This sounds like what happened to @Eric_Schlange_ZwftIn during one of his races that he wrote about on zwiftinsider.com, read the “power downs” section:

Thanks. Well, it’s kind of the same issue I’m experiencing.

Using ANT+ dongle with extension cable placed close to the trainer (Kickr '17).
Newly built top end gaming rig (Windows 10).
Opened required ports in firewall + windows firewall.
WiFi router isn’t running on same as ANT+ (channel 10).

Just trying to eliminate anything at this point, and what I’m left with now, might be the firmware on the older Kickr '17, but since there are others on Kickr V5, this might not be the case…

Any other suggestions to fix this issue are most welcome.

Hi @Tommy_Miland

Sorry to hear that you’ve run into issues with delayed power and surging in front of the pack during races.

Based on the result of your last speed test and being that you’ve made the appropriate exclusions for Zwift in your firewall, it doesn’t seem the issue is with your internet/WiFi connection. But, in order to completely rule out that possibility, you could (if possible) try a completely different internet connection (e.g. another WiFi network or mobile hotspot) for a race, and see if that makes any difference.

Or, try using a different device (e.g. your Android phone or a tablet) for a race or two, and see if the issue is isolated to Zwift on your computer, or if it’s happening on multiple different devices used to run Zwift in your environment.

Also, does this issue happen during every race or only on some races?

Have you tried BLE pairing instead of ANT+? If so, does it make a difference? If not, can you try BLE pairing?

Hi @Steven_D, thanks for the reply.

The PC is on a wired network, pretty fresh Windows 10 install, downloaded the game a couple weeks ago in hopes to increase the FPS in game. Before that i was running Zwift on Nvidia Shield, where i ran it first on WiFi, then cabled, and the issue seems to be consistent, though it’s better on the new PC, with a tad bit higher FPS. But it’s still on the lower end when in a big group, like a race.

Running a RX6900XT graphics card and Ryzen 9 5950X processor, so i would think that would be enough, though the game doesn’t seem to be utilizing the graphics card more than about 60%.

I have also tried to pair via BT on my phone with the companion app, but then the game freezes.

Interesting. So, based on your description it seems like the issue is tied to your in-game graphics or FPS. Since it seems to be running a little better on the newer gaming rig, have you tried lowering the Game Resolution at all from the in-game settings? Maybe drop it to “Medium” or even “Low”.

I realize that doing so means that Zwift won’t look as good graphically on your next race, but I’m curious if running the game at a lower graphics resolution will help to improve matters at all for this particular issue.

As for the app freezing on your phone, that’s odd. Is the phone on the lower end of Zwift’s required specs, or is it a newer, higher performance phone? Do you close all your other apps on the phone, and make sure Zwift is the only app running? If not, that’s advisable since Zwift is a resource-intensive app and might freeze or crash if too many other apps are running on your phone.

Because in that screenshot you are CPU limited. Yes, even with a 5950X. This is simply how Zwift works (it benefits from single thread performance, not core count), and is why dropping the resolution as suggested above will not make any difference to your frame rate in this situation.

The freezing is probably related to the AMD drivers, there is another big thread about it.


Currently it’s running 720, with the auto detected Ultra profile.

From today’s ride:

I would at least expect 60 FPS at that setting, avg is 40 FPS.

To clarify about the game freezing when using BT on the phone with the companion app, the game is running on the same PC, but the Kickr is paired through the phone via BT.
The game isn’t running on the phone itself.

Thanks for the input. That makes sense, although this chart proves otherwise:

Do you have a link to the thread with the game freezing using BT?

Hi @Tommy_Miland

Thanks for getting back to me with that info.

The freezing issue is a known issue, and I think the related Forums thread is here. It’s been one of those ongoing issues and I don’t know that there’s an official a fix as yet.

Since that’s a game bug, I’d suggest you send our team a support request, and we’ll take a closer look at your setup, then advise you accordingly. You can reach us here.

Yeah you still should be getting better results with a 5950X. Told you the resolution setting wouldnt help though. :wink: FWIW that chart is pretty old, your CPU has been surpassed by even i3s now.

Make sure you’re on the High Performance power plan in Windows, and if there’s also a slider on the screen before that, whack it to maximum. If that doesn’t help, try the Ryzen power plan from the AMD website under chipset drivers.

Thanks @Steven_D

I think for testing, it would be a good idea to get a hold of a USB BT dongle first, to see if that fixes the crashing.

Game is not crashing with ANT+, that is all good.

@Dave_ZPCMR Yeah, that’s what i mean, the game isn’t utilizing the hardware as it seems.

I had already tried different resolutions, it makes no difference on the FPS.

But, still, would low FPS explain the delay with power? That’s the question…

1 Like

No, the frame rate tanking when it’s busy (and in basically all of Makuri Islands for no apparent reason) when the CPU bottlenecks the GPU is ‘normal’ unfortunately. But it shouldn’t impact the connection to your trainer or anything else about your experience.


have gotten a hold of a USB BT Dongle and have done some testing.

Right now the dongle is connected to a powered USB Hub, with an extension cable placed near the Kickr.

Connecting the controllable trainer and power through BT, and the pedals and heart rate through ANT+.

First test there where still some ANT+ disconnects, and it came to mind that both the Nvidia Shield and mobile phone still had ANT+ services running, and i uninstalled all ANT+ services on both, and as seen in the attached thumbnail, ALL ANT+ disconnects are now gone, and everything seems to be running just fine.

The game froze once when turning on the Wahoo roam while Zwifting, but killing the process and relaunching and going into the game again while the roam was turned on, the game did not freeze.

Why idk.

I will do a full workout with this setup later today, to see if it works okay.

The power delay seems to be minimal with this setup, going from an even load to zero and back up again, and it’s consistent enough in comparison the ANT+ delay i was experiencing.

It could be that the interference coming from the devices was the cause of the power delay, but i need to do more testing on that.

Just thought I’d share. :slightly_smiling_face:

Did a quick test with the controllable trainer and power connected through ANT+, and it seems more responsive, which makes me think that the devices with ANT+ services indeed was causing trouble.