How to stop the pinwheel?!

Hello all. Received a Kinetic T-6400 for Christmas. I have my Galaxy s-10 mounted to the bars of my Intense spider. Did my first session today. It went pretty well except for the the constant rotating or “flipping” of the display. There were long periods where it was fine, then there would be 10 second periods where it was just spinning. I got dizzy and almost fell off! :grin:
I have auto rotation turned off. Anybody experienced this?

.

My phone is my only real option for the trainer right now. Is there anywhere else I might get help with this? -ted

Hi @Ted_Dake, welcome to the forums.

Does this happen when the phone is not on your handle bars too? Could the mount just need to be adjusted so it tilts more?

1 Like

Mike,
Thank you for your post. I tried tipping the phone up a bit on my one and only ride but it did not help. My new trainer tire showed up yesterday so I will be on the trainer today.
I don’t understand how the display can rotate then “auto rotate” is turned off in android. I thought there might be a “in app” setting for this in Zwift but I do not see one. I’m kinda surprised more users haven’t had this problem. -ted

I just tried on my Android phone, and it doesn’t rotate at all in Zwift unless I turn the phone round far enough that it flips 180 degrees (still in landscape mode).

Are you saying that yours flips to portrait mode? You mention rotating, and spinning, but by how much? 90 degrees? 180? 360?

The display rotates 180 degs only. Zwift appears to a “landscape only” app.

.

So you’re saying it goes upside down and back again? If so, that’s very odd - does it happen in other landscape-based apps?

So you’re saying it goes upside down and back again? Yes, rapidly

If so, that’s very odd - does it happen in other landscape-based apps? I have no other landscape only apps that I know of. But I can say that as long as auto rotate is off in Android, all other apps behave as they should.