Zwift app constantly rotates - Samsung Galaxy S10

Hello!

As I do not have my own treadmill I go down to my local gym to do some indoor running. In order to run on Zwift as well I connect my HR-strap and footpod to my Samsung Galaxy S10 via. ANT+. All works beautifully. Except for a quite annoying detail:

Because of the bounce in the treadmill the Zwift app rotates about 2 times per second. I have tried several “fixes”. Disabled auto-rotate in the dropdown menu in android (both before and during a zwift-session) and a 3rd party “screen lock” app. Nothing works. It is very frustrating. I have experienced this over the last year over several Zwift and android updates.

I do not know what code-snipped that actually tells Zwift to rotate based on the gyro-sensor in the phone but I imagine the simplest fix is to add a “disable rotate screen” in the seetings in the Zwift app itself.

Please help me out so my lactic rage dont cause me to throw my phone at the guy running next to me…

2 Likes

I have the same issue. Is there any resolution?!?!

I have not found a solution yet. Shame that we have not heard from the Zwift-team regarding this.

I have an S10. In the interests of experimenting I’ve just replicated the bounce of a treadmill by shaking my phone and yes it does keep rotating. The same motion doesn’t cause rotation when not in Zwift.

Also tried it on my galaxy tab a7 and the same.

The s10 is far more sensitive though.

I’m guessing whatever ledge you have your phone resting on isn’t quite stable enough to not cause the bounce. I’ve a NordicTrack T10 and it doesn’t cause the issue.

Interesting experiment, Stuart!

I have had similar experience also. It sees that Zwift is far more sensitive than the regular android experience.

I tried a different treadmill on another gym the other day, with a different angle on the ledge. Was more stable there.

A setting in Zwift to block the screen rotate function will solve these issues.

1 Like