How do I stop zwift from looking for Ant+

Long story short - I previously has a usb ant+ dongle in my PC. I removed the dongle because it was needed elsewhere but now everytime I start zwift I get a popup telling me that the Ant+ dongle wasn’t detected and then some stuff about garmin express being the issue (yadda, yadda, yadda). I want to know how to stop this thing from popping up everytime I try to ride, there is no longer ant+ on this machine.

I’ve tried uninstalling the dongle from the device manager (then physically removing it from the usb port) and I’ve tried reinstalling zwift completely but the issue persists.

Any thoughts short of formatting my OS would be greatly appreciated!

Uninstall Garmin express.

Um no, that’s not a reasonable solution.

  1. There is no ANT+ dongle so obviously garmin express isn’t interfering with anything.
  2. garmin express is needed for my garmin watch

When you reinstalled Zwift did you delete the folder in Documents? If not it will have retained your preferences and config files. Try deleting knowndevices.xml.

Thank you that’s a good idea. I just tried it but unfortunately it didn’t fix the issue. I also tried hunting for any additional hiding spots zwift might have been hiding config data (program data/appdata/etc) but still no luck.