How can I prevent automatic updates?

The update procedure is terrible! It always takes several restarts of the application. The last big update (last week) took 15-20 minutes to install (with two or three restarts). Today I received another update. Again the process got stuck and I had to kill and restart the process.
May be they should review their software quality procedures in order to reduce the number of necessary updates?

Is there a way to prevent Zwift form updating automatically? Manually starting the update once a month would be a good compromise.


Btw: It‘s a powerful PC with current Windows and updates and a fast Internet connection. It normally runs Zwift with 4K resolution and no problems.

It might be a “powerful” PC, but it sounds like it has a slow HDD and not an SSD. Am I right?

1 Like

On a powerful PC with fast internet it should not take more than 3 minutes. On my second potato PC it takes less than 5 minutes (only Zwift on that PC).

Something is not right with your system.

It is good to restart after a Zwift update.

1 Like

Do you have background updates checked in the system tray?


Of course the PC is with SSD. And yes, I have unchecked the background update.