Help with H3

Hi. I’m brand new to this and have literally just set up my H3 and logged into Zwift.

My (continued) issue is that my Watts are intermittent despite my cadence showing. I’ve re-downloaded the app. I did try to calibrate using Zwift but see that isn’t working but I just can’t seem to get it working. I’ve been on it for at least 30 minutes but it’s logged 3mins and .3 of my free 25k!

I’m using Bluetooth to an iPad.


Hi @Andy_Hilton1, welcome to the forums.

Sounds like you might be getting bluetooth interference from some other device or electromagnetic field. Try eliminating all other devices in and around the area your bike is set up at.

@Gerrie_Delport has an H3 too, but uses ant+ on windows 10, but he might be able to help.

1 Like

HI @Andy_Hilton1 when I first hooked up my H3 the watts weren’t always showing. I know it sounds ridiculous but I had to delete Zwift and then re-download the app. It worked after that. Maybe you already tried that but it worked for me.

Yeah I did delete and re download the app.

I’ve also calibrated it via the Saris and Rouvy app and that was fine but when I go to ride on Zwift or Rouvy for that matter my watts just plummet to 0 despite me pedalling.

I’ve nothing else in the room other than the iPad and my iPhone

It’s really frustrating

Hi @Andy_Hilton1 welcome to Zwift forums.
Shuji at Zwift HQ here. When you reinstalled the app, you should have been prompted to allow certain folder permissions - did you say yes to all the prompts? These prompts allow the Zwift app access to run correctly. If you’re not certain how you responded, please delete the app and try again.

I’m looking at two partial log files from your sessions that were saved to our servers. I uploaded the logs to, which is a third party site that diagnoses your log files for issues. Your Bluetooth signal is definitely irregular.

You can locate the more complete log files on your iPad and upload them to zwiftalizer if you’d like

A lot of common household things produce electromagnetic noise in the 2.4Ghz radio spectrum that Bluetooth uses: fluorescent light fixtures, fan motors, microwave ovens, etc. Here are some things you can do to reduce interference.

1 Like

Thanks for this. No I wasn’t asked for anything. I just logged in again. In terms of Bluetooth interference the nearest thing is an Alexa in another room. It’s just me. My phone and my iPad. I will delete the app and try again but I’m getting really frustrated

Also try changing the channel on your wifi, it is listed as an idea in the link Shuji provided. Something is causing the bluetooth to be disrupted. Turn bluetooth off on your phone too.

Just tried it again. Deleted and re downloaded app. Unplugged Alexa in next room. Only took iPad in room with me. Still the same issue. I’m unsure how you change Chanel on WiFi as we only have one WiFi option. I’ve unplugged saris and turned off / on Bluetooth but no change

usually there is a website link printed on the router, look on the bottom maybe, that is where mine is. It directs me to where I can change the channel.

1 Like

Hi all, I’ve removed all bluetooth interference things I can think of and tried the iPad a little further away on the landing and then my wife held it literally next to the sensor on the H3 and having same problems. Both cadence and watts all over the place and then dropping to zero.

I also tried the Zwift troubleshooting guide.

I am stuck!

@Andy_Hilton1: You might also try setting your WiFi to a fixed channel, instead of letting it look for the ‘best’ channel. Sometimes this can cause regular and repeated drops in signal as the router changes channels and the iPad is constantly trying to adjust to that. And if you happen to be using an iPad with cellular service, be sure to turn that off so that it is not competing with the WiFi signal.