Heart rate drops to 0 since last update


already reached out to you a couple of times in the last two weeks with the same problem. The heart rate keeps disconnecting. Suddenly. It just drops to 0. And it shows me a disconnect on my cell phone,

Tacx Neo 2T
Garmin heart rate belt Triathlon HRM Pro which has an Ant+ / Bluetooth built in ….

It was all running normal till like two weeks back when I experienced it the first time. The heart rate on the Zwift app suddenly just dropped to 0. So I exchanged the battery. It worked for one day then again after 45 min- back to 0 and I get a disconnect message on my cell phone. I opened both of my heart rate belts and exchanged the battery again. Same story, it starts completely normal then after like 30-40 mins- back to 0. I bought a new heart rate belt same story. After recording for some time- drop to 0. I also got the web page sent from you with all possible disturbers sent( like microwave/other Bluetooth/…) and things like that but I don’t find any mistake. Also if there would be a mistake it would not start to record when starting a new session as if there is nothing. It would not work from the beginning….so I am just totally buffed and curious what the reason is….any idea?

Basically the problem exists since the last update.

Same issue for me…
This is really driving me nuts, i think i already tried everything

  • switching off BT on all devices except my PC running zwift
  • updated my USB BT-stick’s firmware
  • updating Windows
  • downgraded Windows
  • deleting prefs and knowndevices files
  • updating visual studio

This is tied to “no signal” thread here in bugs subforum.

But in my case only my wahoo tickr keeps disconnecting. And when i look in the pairing screen it says “no signal”, sometimes it reconnects and gives me my HR-reading and sometimes i have to unpair and pair 4 times before it gives me HR-reading.