Having issues with not joining the Robo Pacer? [May 2023] [SOLVED 1.42]

Yes, it should be fixed over the next couple of days with release 1.42.


My wife has started Miguel 2-3 times on each of the 2 routes and doesn’t join pace partner . . .

This has now happened a few times :frowning: So frustrating

As above it’ll be fixed with the update

1 Like

Thanks @Michael calfzilla and @James_Zwift !!

I checked and I had 1.41 on my AppleTv and have just updated to 1.42 (released yesterday in the App Store) and I’ll give a try in the morning…

At least Coco has been on Volcano Loop this week, so if I drop in away from the pack, I don’t have to wait long for them to show up :slight_smile:

As James notes - this issue has been resolved in Zwift version 1.42. We’re doing a a phased rollout over the next two days - please update when when it’s available to your device.


Since the last update, it’s difficult, at best, to join a pacer. Can this “feature” get fixed??!!

This is similar to issues that have been reported previously, but after doing a group ride with Maria, I decided to switch down to Miguel, and he disappeared after only a 1-2 seconds, along with all the other riders that were supposed to be riding with him.

This is HIGHLY frustrating as every time I tried to restart the ride, I needed to go through the bluetooth device connection process, which - for me, at least - is always a slow and time-consuming process.

If by ‘pace bots,’ you mean the roboPacers, I’m running into the same issue. I was able to join a ride with Maria, but Miguel and Bernie kept disappearing after only 1-2 seconds whenever I tried to join their rides.

I’m on a Android device if that matters (Samsung Galaxy Tab A8)

It’s been covered many times in other threads.

This has been fixed in the latest update which you will be receiving imminently.

1 Like

I’ve answered in your other post but to make it easier…

This has been fixed in the latest update which is rolling out as i type.

Are there 2 separate issues? Sounds like:

  1. Trying to join RPs one is dropped nowhere near the RP and the group following the RP. Vs.
  2. Successfully join the RP and group, but then they seem to turn invisible and vanish within a few seconds.

Its not fixed - sometimes it takes after 2 or 3 attempts - last night I was unable to join a D bot even after 5 attempts
Kinda annoying because sometimes I toggle between bots doing long intervals - this effectively killed my session
Apple TV user - normally my Zwift experience is pretty flawless

Are you running 1.41 or 1.42?

I completely agree with you Randy Lots of frustration when you start a virtual ride that doesn’t work. Especially if you’re short on time. On the other hand, I can sympathize with the team of programmers who are constantly trying to improve Zwift. The more features you try to implement, the more complex the program. Perhaps Zwift should stick with a stable version and roll out the latest versions in beta. And the ability to switch between the two.

1 Like

There is one thing that is new though – I think with 1.42. Namely before you could not steer off course when signed onto a RP ride. Now you can, so it’s pretty easy to inadvertently depart from the RP ride if you’re not paying attention, by choosing a turn-off from the RP route with your steering device, when all you meant to do is move to the other side of the road. Using steering to choose route turns didn’t work previously when on a RP ride.

TIL you could change routes by steering. Thanks!

The ability to change routes with steering on a Free Ride started evidently back in Oct/Nov last year. However, until recently (this month), you could not change routes using steering while signed onto a RP ride. At least that’s my experience.

1 Like

What steering device are you using?

Elite Sterzo