Having issues with not joining the Robo Pacer? [May 2023] [SOLVED 1.42]

I can’t join a pace partner ride since recent updates.
The system puts me on the road moving with no PP present. Sometimes I get dropped with a PP showing a little ahead but it’s across the road and flashing or pausing in its colour. Other PP’s nearby on the map are also flashing but not moving. I’ve started doing a free ride to jump in with a PP as it goes by.
I’m using Apple TV/IPhone with all the latest updates.

1 Like

Im also having this problem … 2 for 2 atm trying to join Miguel. On windows pc , only started happening with new updates. Any news on when it might be fixed ?

Still not fixed. Can’t join a Robo no matter how many times I log off and on. Plus we still have the sideways Robo flickering on and off.

Are you on the latest update.

Can you put your log file (of this ride) into Zwiftalizer and share the link so we can have a look.

I’m on 1.41.00. That’s the latest for this app in the app store. I have no idea about a zwiftizer, or how to put something there.

1.42 is being rolled out.

So we have to teleport to a Robo pacer that we’ve already selected? This is becoming so frustrating. Today I had 2 rides freeze up. Couldn’t join 4 or 5 times. At this rate Zwift is less and less attractive. I’m going for a real ride.


You can teleport to another one if you want or you can ride with the one you select from the home screen.

Is it only in makuri islands where you are having RP issues.

A log file in Zwiftalizer will be helpful.

To get the fix you need to wait until you get 1.42. Until then, nothing has changed. I haven’t used 1.42 so I don’t know if the fix is actually a fix.

I have 1.42 and tested the RP no issues on 2 pc’s.

But then again I never had issues with 1.39 or 1.40 or 1.41.

So probably not a good reference point.

Lately it seems with every “fix” there is more that needs a fix. I’m just getting tired of it. Zwift is supposed to be a place to exercise and unwind. Right now you can’t really do either. You look forward to getting a ride in, only to be met with cyber world frustration where the paying customer is being used as a Guinea pig. Zwift should be paying its users.

Zwiftizer? Never heard of it. Sounds like another piece of software. Not doing it. Zwift should be able to analyze there own stuff without using paying customers as Guinea pigs for its “fixes”.

Took me 7 attempts to finally join Bernie in Makuri. When I joined I was the only rider with her. Usually there are many, so looks like others gave up trying. I have had this issue several times over the past few days on 1.41. Apple TV user.


I feel your pain

Unfortunately, Zwift is nearly all software, that tries to operate on a variety of platforms, and there will be bugs. Even in the commercial space, there are bugs, and often consumers are asked to run diagnostic software to help the vendor pinpoint issues. I totally get not wanting to be part of such an ecosystem, and letting your money do the talking. A vendor that controls both hardware and software, like Peloton, might be a more stable platform. Alternatively, you can put your subscription on pause while they sort this feature out.

The recent instability in joining pacer rides is irritating, but I can always go on a solo ride if I can’t join a pacer.

I did that and perhaps will have another try in a few months time and keep an eye out on this forum. In the mean time I moved my rides outside and also will try various other platforms to compare with Zwift.

I just want to know if Zwift is aware of the issue and workin on a fix…

It’s fixed in 1.42, I was having issues on 1.41 but none on multiple occasions with 1.42.

1 Like

Despite my repeated attempts to locate Jacques on the map, I was unable to find him, so I ultimately decided to ride with Yumi. Could this be a glitch? :face_with_diagonal_mouth:

Yes, it should be fixed over the next couple of days with release 1.42.