Hanging in connect device page

I can’t connect to any devices, when I get to the connect device page zwift starts lagging and no devices appear to connect to. the rings around the ant + don’t move and if I skip the connection it takes about five minutes to load Watopia. once in watopia everything is normal except I can’t ride because nothing is connected. if I go back to the connect devices page the program will crash. windows 10 pc. multiple computer restarts and program restarts to no avail. a few days ago everything worked fine…



Try reinstalling Zwift?

1 Like

Yeah i forgot to add that after waiting 30 minutes for that to download and reinstall zwift nothing happened. So as i was digging for answers here, i tried updating the usb ant + drivers and Microsoft would not let me do that because they were “already the latest” . In the meantime I did a Microsoft .Net update. Restarted the computer for the 16th time and like magic every thing was back to normal :thinking: not sure the .Net update had anything to do with that but atleast it is fixed and I only lost 3 hours of my life :upside_down_face: and missed a workout.