graphics settings

how do you find out what your current graphics settings are - I’m using a gtx970 and my currentconfig file says 1280x720 ?

is there some other way to tell ?

You can find some information here in responses:

With a 970 you should easily be able to run it in Ultra…wonder why it isn’t defaulting to that?

Thanks for the reply - the log files say Ultra so I’m happy :slight_smile:

I`m trying to update my config file to show the FPS, as shown :-

but I am not able to save the new txt file. Anyone any ideas ??


Look for a line reading “using xxxx graphics profile” in your Log.txt file:

[20:31:22] Using high graphics profile

In this example, it’s using the high graphics profile. So, edit your high.txt config file. If it reads:

res 1280x720(0x)
sres 1024x1024
aniso 4
set gSSAO=1
set gFXAA=1

…then add the FPS line like:

res 1280x720(0x)
sres 1024x1024
aniso 4
set gSSAO=1
set gFXAA=1
set gShowFPS=1

I can input the fps line of code into the config file in my setting (high) but I cannot save the file. I’m not authorised ?


I forgot what I had to do… Rename the old txt file and copy the new one over? Or maybe you just need to change the file from read only?

There’s a few ways to do it. The one I personally use and works best, is to move the C:\Program Files (x86)\Zwift\data\configs directory to your desktop, then use ‘mklink /d’ in Windows to create a directory junction back into the same path.

That looks like this:

  1. Open an elevated cmd.exe prompt from the Start menu
  2. cd \Program Files (x86)\Zwift\data
  3. move configs %HOMEPATH%\Desktop
  4. mklink configs %HOMEPATH%\Desktop\configs
  5. Right-click configs folder on your desktop → Properties and uncheck “Read-only”, then Apply

Now you just have to open the appropriate file from there edit and save it. The file changes will be immediately reflected in the referenced copy in \Program Files (x86)\Zwift\data\configs.

When Zwift is updated, it shouldn’t change this junction. If it does, just go through the same process again, but make sure you back up those files and their changes first!

Hope that helps!