Graphic card 99% load


i am new to Zwift and i’m experiencing some weird behavior of the app. When i open the Zwift app, my 16GB AMD 6800XT graphic card goes like a hairdryer… and all the load is caused by the Zwift app. What is weird - this happens before i even select a route and start riding - in the main menu. Anyone can help? CPU is doing basicaly nothing and i have 32GB of RAM. My computer is used mainly for PC games, which run pretty well in 2K and the graphic card is almost silent…

Force vsync or enable a frame limiter.

It’s your FPS going berserk and your GPU trying to produce as many frames as it can because nothing is telling it to stop.

I’ve never owned an AMD card so you’ll have to google how to set that up in your drivers, because Zwift doesn’t have a vsync option

1 Like

99% is normal, means the gpu is doing the work rather than the cpu

1 Like

That was exactly my guess because changing the video resolution had no effect. So i have to find a way to force it… wish me luck :smiley:

It would be normal on a old graphic card with 1GB VRAM… but not on a 16GB (basicaly) top tier card.

i also don’t own an amd card but you should be able to do that in adrenaline, if not you can use an app like rivatuner. i set my global fps limit to my refresh rate, as far as i understand i don’t think there’s any point to having it any higher

Generally speaking no; there are instances where monitor timing can be improved by having some weird % based FPS above your monitor, but the reality is… we aren’t playing Doom or Quake Arena, so that discussion serves no purpose here.

Ideally, a best rule of thumb is to just set a global max FPS 1-10 frames higher than your monitor’s refresh rate. That will give a buffer, and if you can figure out exactly what your monitor likes, can reduce tearing (as opposed to something like vsync which usually will cut back more frames than necessary across the board).

Ideally though; Zwift certainly needs to do some FPS limiting natively, as runaway FPS isn’t good for… anything really. (I doubt this is an issue on tablets, but if it is, is a good way to chew through battery power)

On this topic though, this is something everyone should be doing; not just those with higher tier cards.
Limiting FPS is a benefit to all users.

This can happen on the menu screen.

The normal ‘bottleneck’ for Zwift is the CPU, when actually riding that will max out first, its unlikely your GPU would be at max load. However on the menu screen the CPU load isn’t there as its a static screen so the GPU can go nuts. I don’t know why this happens but the fix is to set a frame rate or FPS cap. With Nvidia you can do this via the Nvidia control panel, I assume there must be something similar for an AMD card.

Solved. Thanks to all for suggestions.
Well, all this could be solved by one ON/OFF button in the Zwift app settings :slight_smile:

What i had to do:

  1. Open AMD Adrenalin
  2. Add ZwiftApp.exe manualy as a “game” because Adrenalin is not detecting it as a game :slight_smile:
  3. in the ZwiftApp settings put the vsync thing “Always on” - option right below the Radeon Enhanced Sync (in Czech language on added picture)

i have the same problem with my 6800.
What you did is a Workaround but not a solution for me.
GPU is between 66% and 79% with vSync. Thats better but i am still getting 240 FPS.
The FPS limiter is not working on Zwift for me.
I set the limit at 140 FPS…

66-79% is normal for 240fps with that kind of hardware. but there other ways to set an FPS limit other than adrenaline if that is not working. rivatuner/msi afterburner should allow you to do that