Gibberish / incomprehensible text - even worse after update

I have been encountering a number of issues with Zwift for the past year or so, which culminates in a number of problems; namely a stuttering of the game, followed by gibberish/incomprehensible text and then sometimes a complete and total crash of the zwift program.

This has been going on across a number of worlds, namely France and Makuri Islands - but has not ever affected Watopia. This has been getting progressively worse and more and more frustrating, I have logged a ticket previously but this has not been replied to (aside from the automated initial response). With the update to the new version of the game (Neokyo expansion), the problem has now become even worse, before I could sometimes complete a ride without encountering an issue or even complete it when the text was gibberish, but post-update the entire screen becomes gibberish as soon as the zwift world is loaded.

I’m unsure how to solve this and its becoming increasingly frustrating to be paying for a service that I cannot use in the desired way. I have tried different permutations of the following to try and solve this issue:

  • Graphics run on high, medium and low
  • Devices paired via bluetooth or ANT+

My laptop is running Windows 10, with an AMD Ryzen 3 processor and Radeon Vega graphics so should be able to run zwift in one form or another. If it would be helpful I also have the FIT files (not uploaded with this post) from the rides.

I’d start by running the memory diagnostic test (just hit Start and type it in), because this looks like corruption of data and so I suspect the RAM and/or APU.

1 Like

Or GPU RAM which may require a separate program to do GPU RAM tests. Possibly try running in the lowest available resolution and see if anything changes.

Looks like a few other people reporting this same issue post upgrade…
We have a club member with it and there is similar post on zwift riders/racers Facebook group…

He’s using an APU, the system RAM is pooled.

This happens all the time to me on France and Makuri… Exactly the same. Is this program bug or are there any known fixes?

I don’t use my laptop which runs windows10 anymore i now use an android samsung tab s5e
and have had no further problems on any zwift guest worlds

Looks like not using the stock fonts of windows? Do you have any themes installed that change the system fonts by any chance?

It’s some sort of issue specific to AMD graphics. Could be a driver issue or perhaps some sort of system resource shortage which is corrupting the text.

1 Like

Ug… same deal. Win10 AMD laptop. Watopia is fine but any other world gibberish. I just tried the set Graphics to Performance with Zwift… France loaded… but then when loaded workouts… screen went to poo.

Is this app only good for Tablets/phones? Seems all screen issue point to PC users.


Since my last post I have upgraded the RAM with a further 8 GB and have completed a number of rides on France and Makuri and have had no further problems with drop outs or gibberish

Agree with most here. I had the same issue on my laptop (AMD chip, 4GB RAM). I took the laptop to the computer store to upgrade the RAM to 12GB - $50 for parts and work. The issue is now fixed.

1 Like