Garmin Dual-HRM/BLE/Android

I hope this will help someone with the same issue.

Short version: can’t connect and/or get correct data readout from Garmin Dual-HRM; Network Settings reset on the phone fixed the issue for me (at least temporarily, for the few short tests I’ve done so far).

Now the long version:

My setup is the Elite Suito trainer and Garmin Dual-HRM connected via BLE to Zwift Companion app on the Galaxy S10 (North American/Qualcomm version, recent upgrade to Android 11/Samsung UI 3.0); the phone is on the same network as the Win 10 PC with the actual Zwift program. Latest available updates on all the equipment.

Of note: other things connected to the phone via BLE are Galaxy watch and Galaxy Buds, this has NEVER been a factor; the setup either worked, or it wouldn’t, regardless of these variables.

The whole thing worked “out-of-the-box” for a while, and then I started having intermittent BLE connectivity issues extensively described by other users on the forum. Either the HRM connection would break (“No signal”, HR of zero, or some other constant erroneous number), or the trainer connection would be lost (10-15 seconds into the ride). Usual workaround/troubleshooting measures – unpair all Bluetooth things, restart apps, reboot phone, clear BT cache, power cycle the trainer, reinstall apps – would eventually work for a few rides, and then I’d have to go through the whole process again.

Recently, the usual workarounds stopped working, and no amount of reboots/reinstalls/cache clearing/swearing etc. would help; the HRM would connect but wouldn’t show HR data. The trainer would consistently and properly connect though, so I’d only be missing the HR data. Naturally, I blamed Zwift (and Garmin), since the HRM would seamlessly and consistently connect to my wife’s Peloton app on Galaxy Note 9 (Android 10), showing the correct HR data.

Testing. In an attempt to figure out which link in the chain was faulty, I did the following:

turned off the BT on the PC next door;
checked continuity on the chest strap (yes, correct continuity);
replaced the battery in the HRM (old one was reading 3.08 volts, new one was reading 3.08 volts);
tried connecting HRM and trainer to the Elite MyETraining app (connects correctly via ANT+, but the same issue with BLE; the trainer correctly connects via either);
installed the Companion app an older Samsung phone that happened to lay around – HRM and trainer eventually correctly connect;
installed Zwift program on a Win10 laptop with built-in BT4.0 – HRM and trainer correctly connected…

Final bit was trying to connect HRM to Strava app on my S10 (connects, no HR data) and then to Strava on my wife’s Note 9 (connects correctly). So… the phone?

Factory resetting a daily driver is a fat ask, considering the possibility of pulling some wrong settings when restoring from cloud backup, so I tried the Network Settings reset (Settings > General Management > Reset > Reset network settings). It worked, for now at least. HRM can connect correctly to Zwift (albeit, the connection takes up to 30 sec to stabilize/the red triangle on BT icon go away), and to Strava on my phone. We shall see how long that lasts.

Final thoughts: perhaps Android 11 is partially to blame? The phone OS never asks you to authenticate when you clear cache or data from Bluetooth, or Zwift Companion, or any other app… but it does when you do Network Settings Reset. Some deeper settings/system permissions at play?

Hope this helps someone. Ride on – hopefully, outside :wink:

Alex

“Either the HRM connection would break (“No signal”, HR of zero, or some other constant erroneous number), or the trainer connection would be lost (10-15 seconds into the ride).”

Same issues on my laptop. If i don’t restart the laptop i can’t get decent HR readings.

Thanks for the tip on doing network settings reset, my garmin hrm dual is now working on everything again (was broken on zwift and strava)