Game Update v 1.45 [August 2023]

@shooj i got some blackish red boxes today during a race in Scotland. Latest update 1.45, Win 10

I saw a few black boxes like that on a free ride in Scotland yesterday.

I also had a couple seconds of something similar on a free ride (post workout) on Scotland on Monday as well. W10 also.

Also had a random turn away from the RP route in Makuri today. Haven’t experienced that for quite a while.

Looks like this update broke the ERG mode. I can’t turn on / off ERG mode in workouts.

@david_bevilacqua9826 @Charles_McCarthy_Vel @Joe_Pirrera there will be a fix coming for the graphics profile on M2 Macs soon as part of a larger M1 and M2 Mac update.

6 Likes

Did a long ride with the plays last night and had some weird things happened. I don’t think the right play dropped out at any point but got a few haptic buzzes for no apparent reason, after about 30 mins the ride on bomb graphic stopped appearing although ride on bombs still worked. Steering never seemed to stop working at any point so don’t think it dropped out.

This happened to me yesterday too. I thought the ride on bombs stopped working even though everything else on the right controller seemed to be ok but then I realized if I just held in the button for long enough, it was still doing the bomb.

I had my 1st ever Zwift Crash yesterday in 4 years when changing worlds from Watopia to New York for a Race. I did manage to catch the start but Zwift Play didn’t connect proper. It was working fine before the race and i tested after and it worked again.

Not sure where to post this…
I did a climb portal ride today, Crow Road, in Watopia. Two points/ questions: Firstly, I got the time/summary screen for finishing at the top then continued back down to the bottom and the distance to the flag (end of climb portal looks huge (see picture). Is that what I need to do to compete the route?? So I teleported to a Watopia RP. I followed the RP for a short time and then my avatar automatically turned to go back into the portal for another run up Crow Road. So the second point is if I teleport to a RP after a climb (or from any other ride in the same world), shouldn’t the game leave me properly with the RP or with whomever I’ve teleported to? It would be impossible to start manually turning at every junction to keep on the RP route?
This version of the game seemed to leave me on the old climb portal route even after teleporting.

Wonderful! Any idea when? Thanks!

I’m currently pinned to the left hand side of the road with play controllers turned on. I thought this was to be fixed on 1.44 release? Is it still an issue?

I’m free riding Watopia no power ups etc

Edit - lane hand shifter buttons work fine but steering has stopped

This is a known issue we are tracking where the Ride On bomb button prompt doesn’t appear if the right Play controller is disconnected and auto-reconnects during the activity.

2 Likes

I received the 1.45 update last week (rode it on Sunday and shows in Zwiftalizer). Just received another update…Is it a two-piece? Just wondering…

W11

I have experienced steering weirdness this morning in a race (video is public in Strava event), eventually I was cut off the draft :frowning_face: - I have a Kicr Bike, I know it’s def not a bike issue, as it works fine in free riding. Not sure if this is a known bug. Others?

No, but sometimes the launcher seems to do some sort of housekeeping where it says it’s preparing to update, but then actually doesn’t update.

When will the Apple fix be released? Thanks.

This also just happened to me this morning - the Zwift (macOS) launcher said “preparing to update”, I walked away, came back, launched the game and subsequently my Zwift Play controllers have not been able to connect.

Previously, this latest update had fixed / dramatically improved the Zwift Play connection process. Now only one side of the controller appears in the list, and it flickers on/off the list pretty rhythmically. It persists long enough for me to click the checkbox, but disappears quite quickly. I’m currently disabling any other nearby devices that might be within BLE range, not sure what else could cause the behavior. I already looked for new Zwift Play firmware, and they’re up to date - worth mentioning they connect with the Android phone app as easily as ever.

Broken powerups in climb portal:
2023-08-11-06-57-13

(side note, converting this from mp4 to gif took it from 4mb to 21mb…would be easier to allow direct uploading of small mp4 files to the forum)

1 Like

I did crow road on Tuesday and didn’t have this issue, did you go in via France or Watopia?