Game Update 1.31 [November 2022]

Very often the game freezes using the mouse for UI navigation. I have to use the arrow keys.

Mesh networks aren’t an issue except when it comes to connecting Zwift Companion to the game. Any wifi network can have issues, mesh or not.

The change to “Share with my club” at the end of a ride now always defaults to the last club I shared with.
But if I last selected “No Club”, it still defaults to the last actual club I shared with (even if that was weeks earlier) - rather than defauting to “No club” which was my last selection.
If I don’t spot this, it then shares to a club when I don’t want it to.

  1. Can this be fixed to default to the previous selection, not the previous club selected?
  2. How do I remove an activity I’ve shared with a club?

In my opinion, if you see UDP or TCP network disconnects in Zwiftalizer, it’s not clear if this was caused by the server or client’s WIFI network.,

This is a very welcome improvement, thank you!

1 Like

This other thread has at least one user that found the mesh network was the issue.

There’s zero evidence that it was anything to do with it being a mesh network, as opposed to it being a different wifi issue.

One single report of a wifi issue on someone’s network (which hapoens to be mesh-based) doesn’t mean that suddenly mesh networks are no good for Zwift.


We rode a meetup there this morning. A warmup for WTRL TTT. Pretty cool scenery.

Cool! I tried later on in the day and was able to select one of the new routes. Looking forward to sight seeing!

Yeah, the 2D map was pretty much unusable in some places. The magnification varying depending on where you are isn’t new though, it also happens at least in the Harlem end of the NYC map. I don’t really see why it would not just stay the same (whichever of the three options you choose) wherever you are, even the less extreme NYC variant is a bit confusing.

1 Like

A post was merged into an existing topic: Urukazi update: Audio echoing and VERY LOUD

Same. Not on ATV as of Thursday morning mst

Have you checked that lately? I downloaded the ATV version yesterday afternoon (MST).

hello in the new routes I don’t see the complete route to make the badge and they don’t give me the mech isle loop badge (for example)

Hi @Jordi_Riu_Popito, it looks like you made a manual turn or something in your Mech Island loop activity, maybe it was just a glitch. I got this badge yesterday, it was the first route I rode on the new expansion and it worked fine. I then did 2 other new routes and both worked, got the badges.


This definitely isn’t the Mech Isle Loop route.

I lost all my progress of my trainingsshedule…im in week 6 of active offseason and now its all gone…


Me to on the “build me up plan”

Updated my companion app and went for a ride …my HR kept constantly showing 0 then HR and then dropping again throughput the ride. Using ATV and Apple Watch. Anyone else having this problem today?

Same here - was 3 weeks into Build Me Up and all gone. Unimpressed.