Flux S Smart - Zwift Companion fluctuating resistance in climbs

Hi All,

anyone has idea what can cause fluctuating resistance in climbs 4% and more? If i connect Tacx directly to Apple TV over bluetooth, it works just fine. When i use connection thru Zwift Companion i have the resistance fluctuating.

On iPad using ZC it also works fine.

Setup:
Apple TV newest firmware
Tacx Flux S Smart newest firmware
Polar H10 heart rate monitor connected to Zwift Companion
Polar Cadence connected to ZC

Thanks,
Jakub

I have similar issue with resistance on hills fluctuating randomly. Tacx Flux and Android.
Very frustrating?!

Hi, I see no one from Zwift has replied so here’s hoping!!

I also have a problem with my Tacx Flux S and fluctuations in resistance.

As soon as I hit a climb over 4% on average the resistance fluctuates from 4w/kg to 1.5w/kg and back every 3 or 4 seconds for the duration of the ride. I have cycled up ADZ and it was horrific for over an hour.
I have spoken to garmin support and they suggested I tried workouts on the Tacx training app; so I cycled up Alpe D’Huez to get a comparison- no problems at all, in fact the experience was very smooth. Went back to Zwift and boom resistance fluctuates.

Any ideas what the problem is?

My set up is:
Tacx Flux S 2020 (3 months old)
iPad 6th generation V14.2
Zwift - latest update 1.0.58982
Bluetooth
Sim not erg mode

Hope you can help as it’s putting me off cycling on Zwift but Tacx is so boring!!!

I experienced the sam problem while climbing Alpe du Zwift.

Tacx Flux S connected to Windows 10 through Bluetooth.

I keep experiencing this problem in every climb that goes above 5%.

If it is useful information, I’m a heavy rider (90 Kg).

I usually use Ant+ to connect my Flux S, decided to try out bluetooth on my last Alpe ride to see if the resistance latency would get any better with it. At the start of the route everything was fine, but once I hit the climb the resistance started oscillating between 100 and 300 watts until I gave up after a minute and switched back to Ant+, after the switch the problems went away and everything was back to normal. Tried to include a screenshot of it from Strava but I wasn’t allowed to include an image or link…

I’ve noticed that my phone has Ant+ connection. I’ll try by running Zwift on it and let you know…

Anybody managed to figure this one out? Getting exactly the same issue. The Alpe is no longer worth riding and it ruins a race as the 70W power drops means you get left behind

A temporary fix that works for a few weeks at a time for me:
Recalibrate the trainer on the tacx utility app(using normal methods like 10min warm up before), then reconnect to zwift and it should be fine!