Fit Files and Strava


(Steve Troughton) #1

Help anyone, having trouble uploading rides to strava and accessing my FIT files.
Have read many help topics but still no joy. Zwift says I’m connected to Strava, likewise Strava says I’m connected to Zwift yet still when I end ride and click Save+Strava no rides auto-upload.
Can’t find FIT files to manually upload either. No files appear in Documents - Zwift - Activities.  Help files say that I should be able to find these on my Dashboard also. Swift isn’t clear as to what the Dashboard is as no title saying ‘Dashboard’ so struggling where to look which is a little annoying. 
What I think is my dashboard, under my name there is a title that says LAST RIDE but no ride(s) shown and nothing to click on which doesn’t make sense.
Cheers Steve


(S De Vries) #2

Hi, for what it’s worth, I have exactly the same. Nowhere a .fit download to be found… (and all the other sentences :slight_smile:

Cheers


(Steve Troughton) #3

Hi, yes really annoying.  Paying for the service monthly and unable to see any rides or data.  Tried again a couple of hours ago, disconnecting strava, reconnecting, opening Strava before I save my Zwift ride and still no joy.  Wouldn’t be that bad if I could at least access the .fit file to upload it manually.  Arghhhh!!!


(S De Vries) #4

Exactly. However good news, overhere I solved the problem. Zwift programm couldn’t access my default My Documents folder, where it wants to write it’s data. As that drive is default on a network, now I made it offline available, and now it can store it’s data. 

I also updated my Java to the latest version, but guess the first step (ref. folder change) really does the trick. 

Does any similar ring a bell at your place…? Hope this helps you along.

Fyi, once all works out as it’s supposed to be, you will find the download button. Also Strava upload works fine automatically now.

Would be nice if Zwift team can add an error dialog, it can’t write it’s data… now it took me an hour to figure this out…

 

Cheers!


(Steve Troughton) #5

Ah yes, that does ring a bell as the lap top I’m using is a works lap top and usually connected to a network.  I will check later to see if that’s the problem.

Maybe that’s the issue with Strava in that if it can’t write data to a local drive it won’t upload the ride also to Strava.  As you say if this is the problem would be nice if Zwift had an error dialogue box that pops up to notify you.

Will let you know how I get on.  Fingers crossed and thanks for letting me know.

Cheers Steve 


(Steve Troughton) #6

Hi,

My networked drive was set as ‘Always Available Offline’, however not synced which I was unable to do until I came back into work this morning,

Synced networked drive with My Documents earlier and low and behold all my .fit files appeared.  Fabulous!

Thanks for the help and advice.

Cheers Steve