Extremely low fps on some zwift races

Hello everyone,

I have an issue while riding on some zwift races.
I have a I7920 with a 760Nvidia. I can run fine above 40fps while training and overall.
However, in some cases, when I join a race, my fps drops below 1 which makes it unpractical. I tried to play with the config files but nothing helps it.

Any idea about this issue?

I play on high profile with edited settings as below:
res 1024x576(0x)
sres 256x256
aniso 4
set gSSAO=0
set gFXAA=0
set gSunRays=0
set gHeadlight=0
set gFoliagePercent=0.0
set gSimpleReflections=0
set gLODBias=2
set gShowFPS=1

Group events in Zwift stress the CPU more than anything else, so messing with the graphics side is unlikely to reap any benefit. Your i7 is actually very weak in the metric Zwift relies on the most. It should still be doing much better than this though, so monitor your system to see if it’s overheating or throttling in some way. But your focus probably needs to be on the CPU side.

Thanks for you answer.
I don’t think that’s related to the gpu either, as it works fine on training, when a lot of people are nearby. I still get above 45fps.
I was thinking about something unsupported by my config, which is quite old but not outdated (something like PhysX or I don’t know).

I’ll definitely check for the CPU load, but from what I recall, I did not see anything concerning regarding load. It’s overclocked at close to 4Ghz and supports stress test very well regarding cooling.
I find hard to believe that a mid range laptop can outmatch this CPU but maybe I’m wrong :slightly_smiling_face:

Could you give me resources on how group rides differs from regular training with many people around?

It’s not necessarily the load/utilisation, even on a high end CPU it can be sat at a low percentage but the frame rate always tanks. It’s just the way things are in a group event in Zwift, single thread performance is what matters most and the i7-920 is quite poor at this. In benchmarks it’s a long way behind even 3rd gen Intel. However you may be getting power throttling, so I’d download XTU to have a look at what’s happening with the CPU when you’re at 1fps.

GPU utilisation is low in a group event because it’s waiting on the CPU, so frame rate drops. Happens on every system out there. As to why it’s so different to a busy solo ride, I believe it’s due to a higher frequency and accuracy of positional and drafting data being crunched. But I’m not a Zwift dev so I don’t know for sure.

It’s not PhysX btw, don’t worry about that. But updating your Nvidia driver is still a good idea.

I did try joining a couple races with XTU recording file.
First one no problem, 60 FPS.
Second one, 2.5 FPS. It does not seem to be correlated with the number of people in the race (sometimes I get good FPS when there a 150+ ppl, sometimes it is laggy with much fewer people).

This is the data from the laggy race:
Average CPU utilization : 14.7%
Avg Memory : 5.9 GO (I have 12Go)
Max Core freq: 3.7GHz
1 core count
No Thermal throttling
Avg CPU core temp : 51°C

Both races were the following on zwiftpower:
60FPS : /events.php?zid=1219336
2 FPS : /events.php?zid=1219338

I don’t see any difference between these two regarding # of people maybe I am missing something!

Well they’re on different worlds to start with. :wink: But you’re right, something’s off when there’s such a big difference. It tends to relate to people nearby, not necessarily right beside you. So if there’s nobody around, it’s possible to get 60fps in an event with thousands taking part. Or if there’s 50+ near, frame rate will be much lower.

Consider a clean install of Zwift to see if it helps, beyond that it would be a clean install of Windows to eliminate something weird on your setup which is causing the issue.