Events slow to appear on Home Screen

I have recently observed that after logging into Zwift and landing on my home screen, sometimes the events do not show up for up to 5 minutes. Is this a known behavior? Anything I should look at on my device to address this? When this happens, I can navigate to the available worlds and workouts, see the pacers, etc. – just not seeing available events until a little while after initial load.

Details:

  • Windows 10
  • SSD / 16gb of ram
  • Dedicated machine for Zwift / no other apps typically running in the background
  • Ethernet connection

Is this still a problem for you? I have noticed something of the same issue since around January 24 where no events show up at all on the main screen after initial startup, even for events that I have registered for in advance. If I click into the events tab, it shows me no events at all.

I haven’t noticed this changing if I wait, but I have developed another workaround: If I start a free ride, cancel it, and then go back out to the main screen, everything seems to be back to normal with events listed, a join now option for scheduled events, etc.

I haven’t tried anything dramatic like uninstalling and reinstalling, but maybe that’s next - it’s hard enough to get to my events on time without these extra steps!

This happens occasionally for me as well. I usually just restart Zwift, and it works again. I haven’t tried to wait to see what happens.
My setup is very similar to Yours.

Yep, still happens. I am current with the version of Zwift (1.60 now) and current with Windows updates. I will generally just startup the machine and then grab water, etc. before my ride. I haven’t uninstalled/reinstalled but would be willing if someone from Zwift would suggest that as a way to address the problem.

Like you, it takes a while to show even events that I’ve registered for (thus why I start Zwift and then go and grab water, etc.). I’ve also seen that general game load (via Zwiftalizer) is also slower than it used to be.

In the grand scheme of things I guess it’s not that big of deal and since there have been only 2 others that have responded/mentioned this, I suspect it’s not very common and/or not noticed by most.

If you provide details of your setup I’m sure we can help with some pointers.

Also how long does it take to 1. Load Windows and 2. Load Zwift?